This question already has an answer here:

I want to install:

add-apt-repository ppa:ricotz/testin

It is showing:

The program add-apt-repository is currently not installed.
You can install it by typing:
sudo apt-get install python-software-properties

What should I do now?

marked as duplicate by Eric Carvalho, karel, Warren Hill, bain, Radu Rădeanu Jul 11 '14 at 18:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • sudo add-apt-repository ppa:ricotz/testin – prusswan Jul 9 '14 at 5:54
  • 16
    The program 'add-apt-repository' is currently not installed. You can install it by typing: apt-get install python-software-properties – Akankha Ahmed Jul 9 '14 at 6:29
  • Which version of Ubuntu you are using? – Pandya Jul 9 '14 at 13:40
  • 2
    just copyy and paste the command its telling you to do bruh... – Skybbles Apr 13 '16 at 13:23
  • 3
    add-apt-repository is provided by software-properties-common see filelist – TarranJones Nov 3 '16 at 15:46

Try these:

sudo apt-get install software-properties-common

and/or

sudo apt-get install python3-software-properties

and/or

sudo apt-get install python-software-properties
  • sudo apt-get install python3-software-properties show this below Package python3-software-properties is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'python3-software-properties' has no installation candidate – Akankha Ahmed Jul 9 '14 at 6:27
  • 40
    apt-get install software-properties-common seems to be enough in Ubuntu 14.04. – qris May 27 '15 at 20:51
  • 15
    tested this on a docker image. software-properties-common and python-software-properties were required – Thamme Gowda Nov 24 '15 at 1:30
  • 1
    Tested on new Debian, also software-properties-common and python-software-properties were required – Ice09 Feb 28 '17 at 8:36
  • 1
    ubuntu:latest docker image gives E: Unable to locate package software-properties-common – Martin Thoma May 3 at 11:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.