2

I am struggling to get this to work properly.

This works in terminal

sudo bindfs -u dave /media/dave/Documentary2Lin/RAIDMain/Documentary2 ~/shares/Documentary2

How do I get this to work in fstab?

I've tried

/media/dave/Documentary2Lin/RAIDMain/Documentary2 ~/shares/Documentary2 fuse.bindfs force-user=dave perms=a=rX 0 0

It gives an error in fstab

1
  • ~/shares/Documentary2 shouldn't be relative path, all paths in fstab should be absolute (full) paths.
    – user.dz
    Oct 2 '14 at 14:54
1

I finally solved this by using the Upstart system to run all of my bindfs scripts after the file system has loaded.

Create a file:

/etc/init/mount-bindfs.conf

With contents like:

description "Remount directories with different permissions"

start on stopped mountall 

script
  bindfs -o force-user=dave perms=a=rX /media/dave/Documentary2Lin/RAIDMain/Documentary2 /home/dave/shares/Documentary2
end script

According to the extensive and detailed how-to on Ubuntu Forums the correct syntax is something like this:

bindfs#/media/dave/Documentary2Lin/RAIDMain/Documentary2 /home/dave/shares/Documentary2 fuse force-user=dave perms=a=rX 0 0

But this does not work unless the shared directory is in the root partition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.