3

I used a live USB to install Ubuntu 14.04 and completely erase windows 8.1, the installation went fine but when I restarted the computer Ubuntu wouldn't boot from my HDD, instead it came up with try Ubuntu or install Ubuntu so I restarted without the live usb plugged in and I got an error message Reboot and select a proper boot device or insert boot media in selected boot device and press any key.

I read a lot of posts about people that had similar problems but so far none of the solutions that worked for them have worked for me.

I also ran boot-repair but that didn't fix the problem either.

Here is the link from boot-repair http://paste.ubuntu.com/7763898/

Please any help would be appreciated.

My laptop is a Toshiba Satellite U50D-A notebook with AMD A6-5200 processor

  • 1
    Are you booting in EFI mode? Is secure boot disabled? – Eero Aaltonen Jul 8 '14 at 10:28
  • I am typing on a Toshiba Satalite too, I'm pretty sure they are suppored (this is a pro L20). Is there another USB plugged in? That was a problem I have. I would advise disconnecting all peripheral devices. – Tim Jul 8 '14 at 11:07
2

At the very top of boot repair info you posted it says you have two disks

  1. /dev/sda (apparently your hard drive)
  2. /dev/sdb (apparently your USB stick)

/dev/sda has an EFI boot partition and /dev/sdb has an MBR boot loader.

Check boot device

Boot your computer and go to BIOS by pressing one of:

  • F1
  • F2
  • DEL
  • ESC
  • F10

And make sure you are booting from your hard disk.

Check EFI partition

According to Ubuntu UEFI documentation, the EFI System partition should have a 'boot' flag. According to the boot repair info you posted, your partition does not have it.

To fix: boot from Live USB and run gparted. From there you can edit your partition table and add the 'boot' flag.

| improve this answer | |
  • I had a look at my BIOS the boot order is HDD then USB so I dont think thats the problem. – jake90 Jul 8 '14 at 8:50
  • @jake90: Nice :) Since the problem is fixed, please mark my answer as accepted. It will help other people to find an answer here, and it will help me increase my reputation ;) – Eero Aaltonen Jul 9 '14 at 9:29
0

I had the same or a similar problem. Solution: When installing from the USB select install alongside Ubuntu. I think I was actually reinstalling to the USB each time. This worked for me after 3 days of reinstalling, changing boot options testdisk, and as many other things I could find.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.