34

I usually installed flashplugin-installer and by chance noticed that in the partner repository the Flash entry says it's not installed. It also says the package flashplugin-installer will be removed if I install the package from the partner repository named adobe-flashplugin. I've read this answer.

Does flashplugin-installer download Flash from Adobe as opposed to adobe-flashplugin available in the Partners repo? If not, how do they differ?

39

I've just downloaded both packages to inspect them, the process for comparing the packages can be found on the bottom.

adobe-flashplugin

It contains the Flash player library and configures itself as default for Internet browsers. It was only available for 32-bit systems, but since October 2011 a 64-bit version is available too for Ubuntu Lucid and later. This can be installed from the partner repository, see also How do I enable the "partner" repository?

flashplugin-installer

It extracts the 32-bit Flash player library from the adobe-flashplugin package (which is retrieved from http://archive.canonical.com/) and configures itself as default for Internet browsers. Additionally, it installs a 32-bit compatibility layer for 64-bit systems.

Conclusion

There is no change in the installed Flash player for 32-bit systems. For 64-bit systems, flashplugin-installer installs the 32-bit version of Flash and a related compatibility library which may be slower and less stable. I would recommend using the native 64-bit library instead (adobe-flashplugin).

Analysis

adobe-flashplugin was found in http://archive.canonical.com/pool/partner/a/adobe-flashplugin/?C=M;O=D (I haven't enabled the partner repository):

wget http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.3.181.26-0natty1_i386.deb

flashplugin-installer can be downloaded using apt-get download flashplugin-installer. For comparison, I downloaded the 32-bit package from http://packages.ubuntu.com/natty/i386/flashplugin-installer/download.

Programs used:

  • dpkg-deb --control package_version.deb target-dir - extracts the control files (e.g. post-installation scripts) to directory target-dir
  • dpkg -x package_version.deb target-dir - extracts the contents of the package to target-dir
  • dpkg --contents package_version.deb - shows the contents of the package
  • diff -Nur one two - compare directories one and two The postinst scripts were the most interesting as it makes the only difference between the packages.
| improve this answer | |
  • flashplugin-installer as I understand from the answer I linked downloads the Flash libraries instead of having it within itself - but from where? Ubuntu repo or Adobe? – Oxwivi Jun 17 '11 at 20:27
  • The file is retrieved from canonical's servers (the company that supports Ubuntu), not Adobe's servers. – Lekensteyn Jun 17 '11 at 20:31
  • (Currently) the flashplugin-installer (only 6kb) description says "WARNING: Installing this Ubuntu package causes the Adobe Flash Player plugin to be downloaded from the Adobe web site. The distribution license of the Adobe Flash Player plugin is available at www.adobe.com. Installing this Ubuntu package implies that you have accepted the terms of that license." Even though it apparently does it's actual download from canonical as mentioned. (FYI, GDebi is great for looking in deb files too, directly with a GUI) – Xen2050 May 5 '16 at 10:26
0

Ubuntu's own documentation says that flashplugin-installer provides the NPAPI plug-in for Firefox and adobe-flashplugin provides both the NPAPI and PPAPI plug-ins for both Firefox and Chromium.

This answer says that adobe-flashplugin will not be as up-to-date but more stable. I can confirm that my systems with flashplugin-installer get the latest flash much sooner than those with adobe-flashplugin but never noticed any stability differences. Firefox disables plugins that are in need of an update so getting the new version sooner can be beneficial. For example, as of writing on 2019-06-20, adobe-flashplugin 2019-06-11 is still "Proposed" whereas the corresponding flashplugin-installer was installed on 2019-06-13 on other systems.

| improve this answer | |
  • To give an idea of the delay involved, adobe-flashplugin 2019-06-11 became "Released" on 2019-06-24. – yoyoma2 Jun 24 '19 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.