3

I just installed Sublime Text 3 via the terminal from the following commands:

sudo add-apt-repository ppa:webupd8team/sublime-text-3
sudo apt-get update
sudo apt-get install sublime-text-installer

I added the Sublime launcher to my Unity bar, however when I click on it, instead of activating that icon, a grey question mark icon appears in the buttom of the tray like so (it's partially cut off): http://i.imgur.com/OlMI5Mb.jpg. How do I fix this? thanks!

2

I had the same issue, and here's how I solved it:

Adding it via drag and drop from /usr/share/applications using nautilus was always giving me the duplicated unity launcher icons.

I launched the application from a terminal window and used the "Lock to launcher" right click option on its panel icon, which seemed to work as expected once I dropped into the launcher from nautilus.

The problem was the desktop file from /usr/share/applications has some extra features which the drag-and-drop-generated shortcut(located in ~/.local/share/applications) was missing, like "New Window" and "New file" right click menu options, which I didn't want to lose. So I tried to see what's different between them, and the only significant difference I could see was this attribute:

StartupWMClass=Sublime_text

Once I added that to the .desktop file from /usr/share/applications it started working. I then deleted the generated shortcut from ~/.local/share/applications and it seems to work.

I hope this helps you as well.

0

you can replace the default icon like this

$ cd ~/Downloads
$ wget http://icons.iconarchive.com/icons/alecive/flatwoken/512/Apps-sublime-text-icon.png
$ gksu 'gedit /usr/share/applications/sublime-text.desktop'

change this line:

Icon=sublime-text

to

icon=~/Downloads/Apps-sublime-text-icon.png

save it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.