20

After the last byobu's update, I realized that the weird character in bottom left of terminal was not repaired. This character is right or not? See link below.

enter image description here

Ubuntu 14.04; Language: English (US); Regional Formats: pt_BR

  • What do you mean by "not repaired"? There should be the CoF next to the u at least if you use Ubuntu Mono as the font. – LiveWireBT Jul 7 '14 at 18:59
  • I discovered it myself before reading your answer. Thanks anyway. – leoheck Jul 8 '14 at 1:02
28

That weird character, sometimes displayed as ⌷, is the Ubuntu unicode logo, .

Byobu tries to use Unicode symbols, but sometimes those may not display correctly, if you're on a system that doesn't include that character in its font set. All of Byobu's symbols are tested to display properly on on Ubuntu (with the Ubuntu font) within Gnome-Terminal, but your mileage may vary on other terminals (such as Putty), other Linux systems, Windows or MacOS.

You can disable the logo entirely, by going to the Byobu configuration menu, by either pressing F9 or running byobu-config, selecting, "Toggle Status Notifications", de-selecting "logo", and then pressing "Apply".

And you can toggle all UTF-8 characters on/off by pressing Alt-F5, or running /usr/lib/byobu/include/toggle-utf8.

Full disclosure: I am the author and maintainer of Byobu.

  • 1
    Hmm, I am on Ubuntu and I was using terminator as terminal. I just discovered that terminator use monospaced font instead of ubuntu mono. This why this character has never appeared to me. Thanks!! – leoheck Jul 8 '14 at 1:00
  • 3
    That's a nice answer. Could you possibly expand on why I can only see ⌷ within a Putty session on Windows that uses Ubuntu Mono and displays the CoF as in your answer, but only ⌷ where ▴▾ (network activity), ⟳ (reboot required) and ⟫ (prompt) should be? Or should I ask a new question? – LiveWireBT Jul 8 '14 at 12:18
  • Sure thing! Done. – Dustin Kirkland Jul 8 '14 at 12:56
  • @Dustin Do you know why I still have one ⌷? I use Ubuntu mono and UTF-8 in putty. I think it may be the "reboot required" icon. i.imgur.com/7MHykKZ.png – brunoqc Jun 18 '15 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.