1

I opened my laptop after a month of inactivity (Dell, running 14.04). It was in the suspended state during this time, and upon reopening it, the laptop functioned perfectly. After this initial use, I shut down the laptop. When I booted it the next time, the launcher bar had disappeared along with the top bar, leaving me a blank desktop (only the default ubuntu background remained).

I was able to create a new folder and navigate myself through to the Chromium application. I have made multiple attempts to try and fix this problem with the responses already existing on askubuntu. But my problem remains. I've tried to mess around with ccsm, and tweaking unity, but to no avail.

I have little experience with ubuntu, but I will follow whatever instructions you provide. Please help!

UPDATE I know this question has been marked as a duplicate, but I've honestly tried the solutions on that page. Since the original post, Ive moved to a different wifi zone, and as such am unable to connect to wifi from the computer. I'm posting this update from my phone. I request that those who marked it as a duplicate undo that action because it may prevent my question from being answered.

  • @karel I tried the instructions provided on the page. Both main answers were unable to resolve my problem - I can't reset unity. – Karty Jul 7 '14 at 13:21
  • I had the same problem, after rebooting a few times it got fixed in itself. – kenn Jul 7 '14 at 13:39
  • when I try 'setsid unity' it gives me: '(process:4597): dconf-WARNING **: failed to commit changes to dconf: Could not connect: Connection refused' After waiting a few minutes, I Ctrl-C'd out of it. – Karty Jul 7 '14 at 13:40
  • @kenn, Sorry, I've tried rebooting several times in trying to fix the problem. – Karty Jul 7 '14 at 14:13
0

I too have had this problem on a desktop PC for the past two weeks. I've tried most of the solutions on the various threads here to no avail. The launcher disappeared suddenly after a restart following an update.

Finally I decided to experiment. I created a new user from the terminal and logged in as the new user, Unity and the launcher were working fine for this user. As SU I copied the .config and .cache files from the new user and overwrote those of the original user, then used chown -R originaluser /home/originaluser/.config and chgrp originaluser /home/originaluser/.config (repeat for .cache) to change ownership.

This approach fixed the problem though it took me quite a while to tweak the original user so that everything works properly.

This seems to be a multi-factorial problem and appears to be worryingly common in 14.04, though I never experienced it in 12.04, which I used since its release until upgrading to 14.04.

In my view this problem is not being taken seriously enough by Canonical, who seem to be viewing it as a glitch or aberration, when it is clearly a worrying instability.

|improve this answer|||||
-1

I have yet to have this problem... I would try opening terminal and using su command to become super. and deleting the cfg files for unity and compiz to let it rebuild its config.

|improve this answer|||||
  • I've tried to reset unity with the unity-tweak-tool already – Karty Jul 7 '14 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.