For years, nay, decades (literally – two!), I have visual bell enabled in my terminals whenever possible, be it a humble XTerm or Gnome Terminal. Recently, after I switched from Unity to Gnome 3, I had an audible bell (over stereo speakers) in Gnome Terminal.

My searches up to now always seem to lead into the wrong direction: How to enable the audible bell or how to disable the whole thing completely. That’s not my intention. When at the prompt, when I press backspace too often or just before auto-completion, I want the terminal window to flicker, and I do not want to hear anything. Where is this setting hidden?

up vote 27 down vote accepted

Disable audible bell and enable visual bell with:

gsettings set org.gnome.desktop.wm.preferences audible-bell false
gsettings set org.gnome.desktop.wm.preferences visual-bell true

and change the type of the visual bell if you don't need the fullscreen flash:

gsettings set org.gnome.desktop.wm.preferences visual-bell-type frame-flash

Options for visual-bell-type:

  • fullscreen-flash – causes a fullscreen white-black flash
  • frame-flash – causes the titlebar of the application which sent the bell signal to flash
  • 1
    is this going to work on XFCE terminals? Cause it tried and and it did not work. – Soumitri Pattnaik Jul 31 '16 at 8:35
  • This didn't work for me either. – slm Jul 23 at 4:55

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.