My problem is that when I try to install ubuntu or even 'Try' Ubuntu on my computer the mouse will turn on for about 2-3 Seconds then turn off.

The keyboard is wireless and doesn't work either. I am using an old Logitech keyboard for now that works in the PS/2 but i can not finish the install because I need the mouse to do something.

I have tried multiple mice and keyboards. Only the PS/2 works. None of my mice work.

  • Or sudo apt-get install --reinstall xserver-xorg-input-all
    – Aravind
    Oct 3, 2017 at 10:07
  • This article is still helpful in ubuntu 16
    – Aravind
    Oct 3, 2017 at 10:07

2 Answers 2


First install the drivers:

sudo apt-get install xserver-xorg-input-all

If it already installed, reinstall it.

sudo apt-get --purge autoremove xserver-xorg-input-all && sudo apt-get install xserver-xorg-input-all
  • (ALL OFF MY MEMORY) I tried the first one and it said it worked but 0 things were changed/instilled and the second one said cannon't connect to archives.ubuntu.com or something. Thanks for your help but the internet isn't working. My internet is not working it says disconnected, it retry's and disconnects again (Im using ethernet cable) i can ping locally and it works but nothing outside of my house. Jul 8, 2014 at 6:52
  • Ask a new question about that.
    – Tim
    Feb 13, 2015 at 13:33
  • didn't work for me Jul 30, 2015 at 12:56

I know a lot of emphasis is being put on drivers here, that emphasis might be justified for many people. But for my hp pavilion g7 with a kubuntu 12.04 and a windows 7 duel boot setup, and my new acquisition of an hp wireless mouse and keyboard, just unplugging the hp-supplied usb-plugged-in-transmitter out of either of the two usb ports on the left side of my laptop (which seem to work for usb-storage-sticks), where it didn't work, and plugging it in to the single usb port I have on the right side of my computer made both mouse and keyboard work very well. Don't quite understand it though.biker-mike

  • Might be interesting whether maybe the left ones are 2.0 HighSpeed and the right one is a 2.0 Standard or something like that... Could you find that out if they differ in version?
    – Byte Commander
    Apr 8, 2015 at 0:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.