4

I just bought a couple of Dell U2414H monitors, but I don't think this has anything to do with the monitors.

In windows the black levels are perfect, but in Ubuntu the black levels are way off.

Using the test image found at Lagom LCD test I can see all the squares using windows, but only down to 4 using Ubuntu. Why is that, why are the colors/contrast different?

Hardware:

  • Nvidia GTX 770
  • Dell U2414H, connected using DisplayPort, sRGB mode

Software:

  • Ubuntu 14.04
  • Nvidia driver version 331.38
3
  • 1
    Does this help: askubuntu.com/questions/9443/… – krowe Jul 6 '14 at 22:54
  • 1
    I don't have the hardware to calibrate it with, so no. The monitor is factory calibrated and works great on Windows. I'm just wondering why the image is so different on Ubuntu and what I have to do to get it working. Why do I get good black levels on Windows out of the box but not in Ubuntu? – Alex Jul 6 '14 at 23:12
  • I think that you can change the colors with nvidia-settings. – A.B. May 14 '15 at 18:08
2

Start nvidia-settings and navigate to:

X Screen 0 » X Server Color Correction

Change the settings and don't forget to change the configuration. That's all.

1
  • And if you have a problem getting these settings changes to stick, it may be a known bug with saving or restoring the settings file, normally .nvidia-settings-rc. Discussion and solutions can be found at bbs.archlinux.org/viewtopic.php?id=147885 but the short version is to remove hostname references from the file after the configuration is first saved, and/or to change the permissions so that Nvidia can't overwrite it again. – Ethan Dec 29 '16 at 17:05
1

Can you adjust it using xgamma? I haven't found a way to adjust the contrast. But what you can do is adjust the gamma, using xgamma (in xubuntu). Open the terminal and enter something like: xgamma -gamma 0.6. You can play around with the xgamma number (in tenths) until you find something that works.

0

I think xcalib might be able to adjust the black level. If it can, you'll have to enter the xcalib command into autostart to have it run every time you boot up.

0

A possible improvement is to check the nvidia control panel and make sure the "Output dynamic range" is set to full(0-255) and not limited(16-235) for the display as it sometimes defaults to limited.

It's highly unlikely you would want it set on "Limited".

I'm happy with the results after doing this and calibrating it using a X-Rite i1 Display Pro with the DisplayCAL software.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.