2

I recently upgraded to Ubuntu 14.04 from 12.04. My Epson V33 Perfection worked under 12.04, but not any more.

xsane find scanner: "Failed to start scanner: Invalid argument". 

How do I fix this?

Which argument is invalid?

Hardware:

  • Lenovo G585 with AMD 64-bit

  • Epson V33 Perfection

Software:

0a34d3a9b9da6587e9d1a031e5bb0874  esci-interpreter-perfection-v330_0.2.0-1_amd64.deb
b162b55f4fbd037b94489a26e51e0f0f  iscan_2.29.3-1~usb0.1.ltdl7_amd64.deb 
bf7b9e108d8fc15b83726b19c706e8df  iscan-data_1.29.0-2_all.deb
xsane-0.998 package xsane-0.996 compiled with GTK-2.24.18
1

Install the common driver packages from main Ubuntu repository:

sudo apt-get --reinstall install sane xsane xsane-common sane-utils libsane libsane-common libsane-dbg libsane-dev libsane-extras libsane-extras-common libsane-extras-dbg libsane-extras-dev

Then open the application simple-scan and use the scanner with it.

  • The suggested packages were already installed. Then I tried :~$ simple-scan find scanner Failed to scan Unable to connect to scanner :~$ simple-scan GUI starts just fine, scans OK, but ... :~$ xsane find scanner Failed to open device `scanner': Invalid argument :~$ xsane GUI starts just fine, but when a scan is requested, the error message: Failed to start scanner: Invalid argument Xsane is still broken. How do I fix it? Simple-scan lets me scan, but where do the files go? what names? what format? – user301061 Jul 7 '14 at 14:01
  • If already installed, then reinstall and see. I edited the answer – user308564 Jul 7 '14 at 14:04
1

I had this occur to me as well...intermittently....going from 12.04 to 14.04 using my old V100 Photo (USB). It had worked completely smoothly before the upgrade. I tried many things before finally finding the fix. During the upgrade to 14.04, the .conf files were overwritten. I, of course, edited epson.conf with correct address. In looking at the issue again, I noticed in the file that the example doesn't include the 4th hex digit for the <product ID> and <device ID>. I changed usb 0x04b8 0x012d to usb 0x4b8 0x12d Issue fixed. It has not happened since.

Good luck!

0

I've got result when use these directions:

http://www.mogilowski.net/lang/en-us/2014/05/14/install-epson-perfection-v33-scanner-on-ubuntu-14-04/

Go to Epson Download Page (http://download.ebz.epson.net/dsc/search/01/search/searchModule) and download this files (just search for “V33″):

iscan-data_1.28.0-2_all.deb
iscan_2.29.3-1~usb0.1.ltdl7_amd64.deb
esci-interpreter-perfection-v330_0.2.0-1_amd64.deb
(Version numbers may have changed !)

0

Issue came back after an Ubuntu update. I downloaded the latest drivers (running 14.04):

http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2=EN&CN2=&DSCMI=36159&DSCCHK=1285c6147fa7d2741a19e3a4df6d9949c57b39d8 and http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2=EN&CN2=&DSCMI=15835&DSCCHK=3028e98de6ebfd2725e648cc0613d4aa3425e1cd

Removed the old via Software Center, installed the new, I'm back to working. If you don't hear from me here, it continues to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.