my sysadmin set up my work machine such that I don't have root privilege but I can use ubuntu software center to install packages by providing my password.

I login to that Ubuntu machine remotely, and I'd like to install some packages from the software center, how can I do this?

I tried "software-center" , which gives me the interface, but nothing happens when I click on "install"

NOTE: both machines involved are ubuntu machine.

This post might help understand my situation, my sys-admin did the same thing. I don't know how he/she implemented it.

Thank you in advance.

my sys-admin say that the software-center cannot go through X-forwarding, so I cannot install via software center using ssh. But I will try the remote desktop thing.

Thank you all for inputs!

  • Does using sudo work (e.g. sudo echo 1)? Also, from what sort of machine do you want to remotely access the software center?
    – Wilf
    Jul 6, 2014 at 20:58
  • hello, I don't have sudo priviledge.
    – fast tooth
    Jul 6, 2014 at 21:02
  • just checking, as most answers like hwez's won't work...
    – Wilf
    Jul 6, 2014 at 21:03
  • Thanks, I tried "sudo echo 1", returns " you are not in the sudoers file" so I guess I can't sodu. Both machines are ubuntu.
    – fast tooth
    Jul 6, 2014 at 21:13

2 Answers 2


You can use team viewer

For the 32-bit package:

$ wget http://download.teamviewer.com/download/teamviewer_linux.deb
$ sudo dpkg -i teamviewer_linux.deb

For the 64-bit package:

$ wget http://download.teamviewer.com/download/teamviewer_linux_x64.deb
$ sudo dpkg -i teamviewer_linux_x64.deb

& Install it on the other pc that you are wanting to control with
connect by the id & password

  • if the user does not have root access, sudo might not work... However, the package cmight be installable with software center (just download it and click on it). Help for teamviewer is available here.
    – Wilf
    Jul 6, 2014 at 21:00
  • 1
    you can't install any package without root access
    – hwez
    Jul 6, 2014 at 21:01
  • The remote system is set up such that I can install software from software-center but I don't have sudo .
    – fast tooth
    Jul 6, 2014 at 21:04
  • oh sorry you can open teamviewer_linux.deb in software-center
    – hwez
    Jul 6, 2014 at 21:17

Installing/removing software requires root privileges - so when you don't have sudo access you should not be able to install software with the software-center or any other system-method, even if you were sitting at the machine.

I am not aware of a simple method to enable you to install software via software-center that doesn't involve giving you (restricted) sudo access.

Ask your system administrator to allow you to use software-center for installing/removing software when you access the system remotely too - he must approve/deny anyway.

  • thanks for you help, but I don't think you understand my question.
    – fast tooth
    Jul 7, 2014 at 15:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .