I have just downloaded the Android Studio and when I try to run ./studio.sh it gives me an error of

'tools.jar' seems to be not in Android Studio classpath. Please ensure JAVA_HOME points to JDK rather than JRE

I have checked /usr/lib/jvm/java-1.7.0-openjdk-amd64 this folder java is there and I have set the environment variables in




but still, the same error is coming, Please help me out,

after saving this file, if I check


nothing comes and when I try

source /etc/environment

it comes as

JAVA_HOME: command not found

How should I proceed?

  • try this link: How to setup Java-Home and Path in Ubuntu 12.04
    – Lety
    Jul 6, 2014 at 15:33
  • still same error is coming, i have downloaded the Java version again from oracle webiste as suggested on the link, and install it and moved to lib/jvm, but same error. echo $JAVA_HOME is giving nothing.again.. Jul 6, 2014 at 19:14
  • did you add PATH=$PATH:$JAVA_HOME/bin? could you post your /etc/environment file?
    – Lety
    Jul 6, 2014 at 19:51
  • Seems you install only JRE. Visit related question. Jul 6, 2014 at 20:55

4 Answers 4


I got the same error when trying to run the android-studio beta installation. I tried various options, but the one that worked for me was:

sudo apt-get install openjdk-7-jdk 

Didn't have to do anything else.

But, I am surprised that

java -version  

listed the same 3 lines before and after the jdk install:

java version "1.7.0_55"  
OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1~  
OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)



outputs blanks, but now the android-studio is running.

  • wth :O ... it just worked... need nothing to do... just install open-jdk-7
    – Saqib
    Aug 22, 2016 at 18:04
  • ohh i had a doubt earlier... but i was wrong ... working flawlessly Apr 28, 2017 at 17:49

Check the most liked answer. If java is already installed and want to change the priority then

update-alternatives --config java

For me there was a problem with some certificates (seems to be a java bug).
I fixed it with the following (reference):

$ sudo dpkg --purge --force-depends ca-certificates-java
$ sudo apt-get install ca-certificates-java

I had a similar problem and I performed:

sudo apt-get install oracle-java8-set-default

Hope it helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .