1

I have some problems with ethernet on Linux chrubuntu 3.13.0-29-generic.

Network manager shows the network is connected and the device is recognized, but there is no internet. Interestingly it sometimes opens google.com and I am able to input queries, but they are very slow and nothing else works. Here is some info:

user@chrubuntu:~$ sudo ifconfig -a
[sudo] password for user: 
eth0      Link encap:Ethernet  HWaddr 72:b1:b1:c1:d8:46  
          inet addr:129.118.162.17  Bcast:129.118.163.255  Mask:255.255.254.0
          inet6 addr: fe80::70b1:b1ff:fec1:d846/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18700 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2122 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2138423 (2.1 MB)  TX bytes:404200 (404.2 KB)


    user@chrubuntu:~$ lshw -C network
    WARNING: you should run this program as super-user.
      *-network               
           description: Wireless interface
           product: AR9462 Wireless Network Adapter
           vendor: Qualcomm Atheros
           physical id: 0
           bus info: pci@0000:01:00.0
           logical name: wlan0
           version: 01
           serial: 14:2d:27:b3:2a:6f
           width: 64 bits
           clock: 33MHz
           capabilities: bus_master cap_list rom ethernet physical wireless
           configuration: broadcast=yes driver=ath9k driverversion=3.13.0-29-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
           resources: irq:16 memory:e0400000-e047ffff memory:e0480000-e048ffff
      *-network
           description: Ethernet interface
           physical id: 1
           logical name: eth0
           serial: 72:b1:b1:c1:d8:46
           size: 100Mbit/s
           capacity: 100Mbit/s
           capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=asix driverversion=22-Aug-2005 duplex=full firmware=ASIX AX88772B USB 2.0 Ethernet ip=129.118.162.17 link=yes multicast=yes port=MII speed=100Mbit/s
    WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

UPD (netstat-rn and tracepath -n 8 8 8 8):

 user@chrubuntu:~$ netstat -rn
 Kernel IP routing table
 Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
 0.0.0.0         129.118.163.254 0.0.0.0         UG        0 0          0 eth0
 129.118.162.0   0.0.0.0         255.255.254.0   U         0 0          0 eth0

 user@chrubuntu:~$ tracepath -n 8.8.8.8
 1?: [LOCALHOST]                                         pmtu 1500
 1:  129.118.163.254                                       1.894ms 
 1:  129.118.163.254                                       1.899ms 
 2:  129.118.251.29                                        1.994ms 
 3:  129.118.4.246                                         2.197ms 
 4:  129.118.4.233                                         2.707ms asymm  5 
 5:  129.118.4.238                                         2.932ms 
 6:  12.249.227.125                                       10.755ms asymm  7 
 7:  no reply
 8:  no reply
 9:  no reply
10:  no reply
11:  no reply
12:  no reply
13:  no reply
14:  no reply
15:  no reply
16:  no reply
17:  no reply
18:  no reply
19:  no reply
20:  no reply
21:  no reply
22:  no reply
23:  no reply
24:  no reply
25:  no reply
26:  no reply
27:  no reply

I tried to update the driver (downloaded the latest one from ASIX website) , but it seems I updated it to an older version (22-Aug-2005) and it did not help.

When I Ping 8.8.8.8 all the packages are lost.

Exactly the same internet cord works on another computer(desktop) running standard Ubuntu 14.04.It also works on the same chromebook when I use Chrome OS.

Any thoughts?

  • probably a routing issues post netstat -rn and tracepath -n 8.8.8.8 – meccooll Jul 6 '14 at 6:16
  • Thanks. I have updated the post. Any ideas of how to fix it? – Evgenii.Balai Jul 6 '14 at 6:58
1

Looks like the problem is with your ISP. The packets are leaving your computer/network and then get dropped half way through. Call up your provider and tell them to fix their stuff

  • 1
    OOpps didn't see the part where you say it works on the other computer. Very odd. Unless your ISP binds your IP to a MAC hmmm plug the cord into a working computer and post ifconfig -a and tracepath -n 8.8.8.8 – meccooll Jul 6 '14 at 7:52
  • 1
    Do you set your IP manually? Or it got it auto (via DHCP)? Something funny is going on between AT&T and Texas Tech University for that route – meccooll Jul 6 '14 at 7:58
  • Thanks for your help! I found the problem. First I ran the same commands on the computer where the internet worked and the output was the same. Looks like some firewall in between me and AT&T blocks access to 8.8.8.8 (and many other ips I tried to ping) and it was used as a primary dns. I edited my resolv.conf before since the dns that was written there did not work with other internet connection. I copied the resolv.conf from another computer and everything works now! – Evgenii.Balai Jul 7 '14 at 2:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.