1

After upgrading from 13.10 to 14.04 and knowing that gutenprint 5.2.10 now supports Canon SELPHY printers, I've tried installing my CP400 through Settings > Printers.

It finds the printer fine and lists the URI as:

gutenprint52usb://Canon/SELPHYCP400?serial=NONE_UNKNOWN&backend=canonselphy

...and then appears to find the drivers. But when I hit the apply button, I get:

CUPS Server Error: There was an error during the CUPS operation: 'client-error-not-possible'.

If I go to localhost:631/Admin and view the error log, the error appears as:

Returning IPP client-error-not-possible for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-CP400) from localhost

Note that the path in the error is different than the path as entered. Also, it seems that "gutenprint52usb" should have a plus sign in it - gutenprint52+usb - since that would then match the actual file name. I did try changing "gutenprint52usb" to "ipp", per some answers I found in my search. That added the printer just fine, but of course, it didn't work (as in nothing got to the printer).

I've tried reinstalling both CUPS and gutenprint through Synaptic. Rebooted. Plugged/unplugged the printer numerous times. Etc.

If instead I attempt to add the printer through the localhost CUPS utility, it asks for a username and password. I only have one password on this machine and it works every time I log on or need to use sudo, so seems like it should work here but, alas, no. Nor does using my username or root and the same password.

Merle

1
  • It also can be cause because the server URI is wrong or unavailable
    – deFreitas
    Commented Feb 28, 2018 at 22:28

5 Answers 5

4

I was running into the same issue with a different printer. Your comment about the plus sign provided me a clue. When I tried adding the plus sign to 'gutenprint52usb://' in the 'add printer' menu it looked like it didn't accept it. So since I couldn't add a + in the menu, I subtracted it from the library name by making a copy of gutenprint52+usb without the plus sign

# cd /usr/lib/cups/backend
# cp gutenprint52+usb gutenprint52usb

After that, I just added the printer like normal (select device, find driver, save) and was able to print successfully.

3
  • Welcome to AskUbuntu! Suggestion: You could improve on this question by possibly doing a list of how you fixed it.
    – No Time
    Commented Oct 15, 2014 at 4:56
  • Well, whaddya know, that actually worked. Sort of. I can print, so far, only in GIMP using File > Print... Print with Gutenprint did not work. Nor does printing from Shotwell, both of which flash "Waiting for localhost" in the lower left corner of the CUPS localhost:631 window until I cancel the job. Out of paper for now, so will have to wait until I get more to do further testing. Thanks!
    – Merle Hall
    Commented Nov 9, 2014 at 0:32
  • 1
    Thanks for the working solution! Note that a symbolic link (ln -s gutenprint52+usb gutenprint52usb) may be better than a copy. Commented Dec 29, 2017 at 16:47
1

For me, it was the other way around with a Canon Selphy ES30.

The filename had the "+", but the "add printer" menu showed it without a plus.

After using these commands it added fine:

cd /usr/lib/cups/backend
cp gutenprint52usb gutenprint52+usb
1

I had the same problem. Installing the smbclient solved it:

sudo apt-get install smbclient

0

Using Ubuntu Mate 16.04 Canon Selphy ES30 Plug it with USB and try to add via Printer. Printer was found, but Final Step Error:

beim betrieb von cups trat ein fehler auf »client-error-not-possible«

/var/log/cups/error.log

E [21/Feb/2017:22:23:05 +0100] [Client 9] Returning IPP client-error-not-possible for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-ES30) from localhost
E [21/Feb/2017:22:23:05 +0100] [Client 10] Returning IPP client-error-not-possible for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-ES30) from localhost

So i had to do it the other way...

p@fernseh:~$ cd /usr/lib/cups/backend

p@fernseh:/usr/lib/cups/backend$ sudo cp gutenprint52+usb gutenprint52usb 

Worked perfect. Thank you

0

Thanks a lot. I've got same problem with cp500. For others without linux practice is important:
if the command

cp gutenprint52+usb gutenprint52usb

fails, try using sudo to execute the command:

sudo cp gutenprint52+usb gutenprint52usb

have a nice print :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .