2

After upgrading from Ubuntu 12.04 to Ubuntu 14.04, I get a message "scanning for btrfs file systems" at starting-up. I don't have any BTRFS filesystem. It delays the booting for about 15 seconds.

I tried to :

  1. blacklist the brtfs module in /etc/modprobe.d
  2. remove btrfs-tools
  3. renamed the executable /sbin/btrfs to p.e /sbin/btrfs.save

Now i get a blank screen for about 15 seconds until the splash screen appears.

3

Btrfs isn’t too much stable to be used as deafult file-system. Most Linux distributions, probable all, are still using ext4 as primary file-system. So, you can completely remove it from your computer. Try the given command:

sudo apt-get purge btrfs-tools

This command will remove btrfs-tools from your computer. You may need to wait some minutes to complete the process. Your initramfs should be updated automatically but if not happen, do it by this command:

sudo update-initramfs -ukall

Then make a grub update:

sudo update-grub

All is well. Now make a restart. Hope your Ubuntu will start successfully this time.

Reference: http://www.ugcoder.com/disable-scanning-for-btrfs-file-systems-in-ubuntu/

Let me know if you have some questions still.

3
  • Could you please include the essential parts of the answer here, and provide the link as a reference. – Michael Lindman Apr 8 '15 at 10:23
  • Well, ext4 doesn't look too stable either: phoronix.com/… better using ext3 ;-) – Markus Strauss Jan 29 '20 at 10:29
  • This can work but not if you have apps that have btrfs-tools as a dependency that you need. see my post in unix/linux. unix.stackexchange.com/a/630482/201387 – DKebler Jan 22 at 21:43
2

On my system it is not the btrfs-scan which is causing the system to hang at boot. Instead there is a background-process trying to figure out where to find the swap-partition. My system has a SSD and plenty of RAM so it has no swap. This causes the background-process which is looking for a swap-partition to run into the void.

To change this, you can do the following:

  1. In the file /etc/initramfs-tools/conf.d/resume change the statement RESUME=... into RESUME=none

  2. After this update initramfs: sudo update-initramfs -ukall

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.