13

I updated from OpenJDK 7 to 8. I uninstalled 7, which uninstalled the IcedTea plugin as well. I tried to reinstall IcedTea with

   sudo apt-get install icedtea-7-plugin

But it doesn't work. When I try to launch topcoder jnlp file, it fails. Also, it doesn't load any java plugin in Google Chrome. It was fine with OpenJDK 7. Is there a newer version of IcedTea for OpenJDK 8?

14

At the moment, icedtea-8-plugin is not available in the official Ubuntu repositories. Maarten Fonville offers a PPA repository with a working icedtea-8-plugin package.

sudo add-apt-repository ppa:maarten-fonville/ppa
sudo apt-get update
sudo apt-get install icedtea-8-plugin

Bug report: https://bugs.launchpad.net/ubuntu/+source/icedtea-web/+bug/1385842

PPA page: https://launchpad.net/~maarten-fonville/+archive/ubuntu/

If you're using Ubuntu 14.04 (for which openjdk-8-jre is not yet backported), then for the time being the OpenJDK ppa must be added first:

sudo apt-add-repository ppa:openjdk-r/ppa

Recent versions of Chrome do not support the Java plugin (cf. How do I get Java plugin working on Google Chrome?).

  • @jhetzel, I tried but I get an error: Depends openjdk-8-jre but it is not installable. Any ideas? – toto_tico Mar 8 '16 at 15:10
  • 2
    update to this : icedtea-8-plugin is now available in repositories (just got it now with apt-get) – Zanna Apr 27 '16 at 12:56
1

The file you want to install is icedtea-plugin. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install icedtea-plugin
  • On unbunt 14.04 that installs java 7. How can i install icedtea for my existing openjdk8 install? – dan carter Sep 28 '14 at 10:23
  • As far as I know Plug-in 7 is the latest, and it works with OpenJDK 8, and that's what I have as well. – Mitch Sep 28 '14 at 10:46
  • @Mitch How you installed the plugin with JDK 8? When I try to install it, it install automatically JRE 7. – Hunsu Feb 28 '15 at 20:10
  • 1
    As stated in the answer, Plug-in 7 is the latest. I installed OpenJDK 8 form Here, and the Plug-in from Here. Hope it helps. – Mitch Mar 1 '15 at 4:52
0

When you are not sure what's the exact name of package like icedtea-7-plugin or icedtea-8-plugin, etc. Do a package name wise search before installing, for example search for "icedtea" word as follows:

$ sudo apt-get update
$ apt-cache search icedtea

This will display the matching package with word "icedtea" as follows:

icedtea-8-plugin - web browser plugin based on OpenJDK and IcedTea to execute Java applets
icedtea-netx - NetX - implementation of the Java Network Launching Protocol (JNLP)
icedtea-netx-common - NetX - implementation of the Java Network Launching Protocol (JNLP)
icedtea-plugin - web browser plugin to execute Java applets (dependency package)

By this you can decide which one to install..!

With the above output, use:

$ sudo apt-get install icedtea-8-plugin

The prior searching of package name will be helpful for any packages you need to install. If you are having back port issue, for the case of Ubuntu 14.04, then you may refer answer from @jthetzel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.