I've tried getting my Belkin N Wireless adapter to work on Ubuntu many times with no luck at all. Each time I seem to arrive at a dead end.

After some thorough searching of UbuntuForums and WifiDocs I've gathered some information and narrowed the problem down to an issue with the rtl819xU driver.

Here's some info that may help:

$ sudo lshw -C network 
  *-network DISABLED
       description: Wireless interface
       physical id: 1
       bus info: usb@1:2
       logical name: wlan0
       serial: 00:22:75:38:52:ac
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl819xU multicast=yes wireless=802.11b/g/n

$ sudo lsmod
Module                  Size  Used by
vesafb                 13449  1 
snd_ice1724           106559  2 
snd_ice17xx_ak4xxx     13163  1 snd_ice1724
snd_ac97_codec        105614  1 snd_ice1724
ac97_bus               12642  1 snd_ac97_codec
snd_ak4xxx_adda        18436  2 snd_ice1724,snd_ice17xx_ak4xxx
snd_ak4114             14326  1 snd_ice1724
snd_pt2258             12986  1 snd_ice1724
snd_i2c                13831  2 snd_ice1724,snd_pt2258
snd_ak4113             14307  1 snd_ice1724
snd_pcm                80244  4 snd_ice1724,snd_ac97_codec,snd_ak4114,snd_ak4113
fglrx                2434640  121 
snd_seq_midi           13132  0 
snd_rawmidi            25269  2 snd_ice1724,snd_seq_midi
binfmt_misc            13213  1 
snd_seq_midi_event     14475  1 snd_seq_midi
snd_seq                51291  2 snd_seq_midi,snd_seq_midi_event
ppdev                  12849  0 
snd_timer              28659  2 snd_pcm,snd_seq
snd_seq_device         14110  3 snd_seq_midi,snd_rawmidi,snd_seq
dcdbas                 14054  0 
r8192u_usb            297246  0 
snd                    55295  16
soundcore              12600  1 snd
parport_pc             32111  1 
snd_page_alloc         14073  1 snd_pcm
shpchp                 32345  0 
lp                     13349  0 
parport                36746  3 ppdev,parport_pc,lp
usbhid                 41704  0 
hid                    77084  1 usbhid
e100                   40108  0 
floppy                 60032  0

$ sudo iwconfig 
wlan0     802.11b/g/n  Mode:Managed  Access Point: Not-Associated   
          Bit Rate:1 Mb/s   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I'd like to know if 1) Is the driver is properly installed and recognized by Ubuntu? 2) What can I do to load the drivers properly and make use of the adapter?


| improve this question | | | | |
  • I'm struggling to install f5d8053ed (Version.6002ed) device as well. What is the output of lsusb | grep Belkin? I have a 050d:815f device id, which basically means that we both have a chip from Realtek. – Leonid Jun 26 '11 at 14:51

If you have a 050d:815f version that uses Realtek chip rtl8192su then follow the steps below to install the drivers. I've tried it on version 10.04, but it should work on 11.04 as well.

  • Make sure you have 050d:815f.

    lsusb | grep Belkin

  • Create a directory to store the driver.

    sudo mkdir /lib/firmware/RTL8192SU

  • Download the driver. Make sure you have internet connection enabled or use other pc and copy it over to the created directory.

    sudo wget http://launchpadlibrarian.net/37387612/rtl8192sfw.bin.gz

  • Unzip the driver.

    sudo gunzip rtl8192sfw.bin.gz

  • Restart the adapter. Just plug it off and back on. The light on the adapter should start blinking after few seconds, and the list of connections will appear.

If it doesn't work try following the steps outlined in this to troubleshoot and get the exact error message page.

If you're desperate on making it work I'd suggest getting an adapter from this list.

Unfortunately an integrated Wi-Fi card on my laptop is performing by a factor of 30 better then the Belking USB adapter. My Broadband connection is 10Mbit, and the download speed is @ 0.3 Mbit, which is ridiculous. Wondering if that is a problem with Linux or with an adapter. This is my second Belking USB, and I'd never buy another...

After more testing I found that on Windows 7 the same USB adapter performs at 0.8 Mbit in Windows, which is just 15 times slower then the built-in (much older in fact) adapter in my laptop, and uses only 8% of available throughput. Claims that it is "Best for Speed & Coverage" seem to be ridiculous. And the conclusion seems to be that this USB adapter is a piece of crap.

| improve this answer | | | | |
  • 1
    $ lsusb | grep Belkin Bus 001 Device 003: ID 050d:805e Belkin Components F5D8053 N Wireless USB Adapter v5000 [Realtek RTL8192U] Looks like I have 050d:805e. I still have no response from the adapter. No light indicating activity, nothing. I'll take a look at that message page, but I think I'll have to cut my losses and buy an adapter (or PCI card) that I know will work with Ubuntu. – disassembler Jun 27 '11 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.