27

Currently, in about:support (Firefox 30) the "Graphics" section states the following:

enter image description here Now, I know that Firefox has (for whatever reason) disabled the hardware accelerated features for Linux users. However, as stated in this site, it should be possible to force enable it. So far, I have:

  • Set layers.acceleration.force-enabled and layers.offmainthreadcomposition.enabled to true.
  • Set the environment variable MOZ_USE_OMTC=1

It doesn't work, and the hardware acceleration remains disabled. Is there another way to force-enable hardware acceleration (performance is horrible on my computer)? Or am I just doing it wrong?

  • 1
    There is this bug report as well: bugzilla.mozilla.org/show_bug.cgi?id=924403 . The silly thing I find with the 'force-enabled' option is that it seems to be the same as enabling it under Settings > Advanced > General. – Wilf Jul 4 '14 at 16:54
  • Xrender is gone on about here as well - note hardware acceleration does not always mean the results will be faster even though it sounds cooler. – Wilf Jul 4 '14 at 17:06
  • 1
    @Wilf Well on my Windows machines Firefox with hardware acceleration on performs much faster than with simple software rendering. The thing here is whether or not I can enable it just to try it out (and hope for better performance :D) – bubbles Jul 4 '14 at 21:59
25

I try this as a answer even if the question actually gave the answer to me. I had problems setting up the environment variable - because it actually went away as soon as i closed the console. It worked when I started Firefox on the same console I used the export command but nothing else. I tried setting it in bash and zsh. Then I found a solution and now what is described in the question works perfectly for me.

  1. Check if Hardware acceleration is actually enabled in Firefox by visiting about:support looking for "GPU Accelerated Windows 1/1 OpenGL (OMTC)" under graphics. If this shows 1/1 you can stop right here, you not need this tweak. But if it shows 0/1 you can force it on ...
  2. Open about:config in Firefox (url bar)
  3. Set layers.acceleration.force-enabled and layers.offmainthreadcomposition.enabled to true
  4. Run sudo bash -c "echo export MOZ_USE_OMTC=1 >> /etc/X11/Xsession.d/90environment" to set the enviorment variable globally for X (Is no longer needed for up to date Firefox versions)
  5. Reboot and check about:support for "GPU Accelerated Windows 1/1 ..."

enter image description here

  • 2
    This mostly worked for me - Firefox worked faster, but there were graphic glitches and the entire system's graphics crashed upon trying 3D webgl content :(. Using fglrx drivers. Also, note you can test this by running export MOZ_USE_OMTC=1 before running firefox. – Wilf Nov 28 '14 at 14:36
  • or another way to set MOZ_USE_OMTC=1 variable is to create in your home folder .pam_environment file which is dedicated for user environment variables and add MOZ_USE_OMTC=1 – EdiD Jan 10 '15 at 21:37
  • This works though a nicer way to enable MOZ_USE_OMTC on Ubuntu is to add export MOZ_USE_OMTC=1 in your ~/.profile file. – Sir_FZ Jul 10 '15 at 10:37
  • 1
    I just changed it to where the variable is set every time I start Firefox. I use a bash script that runs env MOZ_USE_OMTC=1 firefox. – trlkly Aug 14 '15 at 9:55
  • 6
    @Wilf Current versions of Firefox no longer require MOZ_USE_OMTC to be set at all. Off main thread composition is turned on by default. Setting he about:config preference layers.acceleration.force-enabled to true is now sufficient. – trlkly Mar 26 '16 at 2:08
-4

Try setting gfx.font_rendering.directwrite.enabled to 'True'. Then right-click that entry, click New > Integer, type mozilla.widget.render-mode as the 'Name' and then 'OK'. Type 6 as the Value and click 'OK'.

Source

  • 3
    I think this is a solution for Windows not Linux.... – Wilf Nov 27 '14 at 23:27
  • Maybe. Worth a shot anyway though? You can always reverse it :P – Ads20000 Nov 29 '14 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.