4

I am running Ubuntu 14.04 LTS x64

I have an Oxford Advanced Learners' Dictionary and that comes with a Disk that contains a Digital Dictionary. I don't know how to install it on my computer. Please help me out. Thanks in Advance. :)

1
7

I was able to make the the Oxford Advanced Learner's Dictionary (8th ed) tool working at my Xubuntu 14.04 box. It is not perfect, but it is running. :)

There is no need to install it system wide (i.e., using sudo).

I am considering you have the CD that comes with the Dictionary. Insert it in your machine.

Now, follow these instructions in the terminal:

1) Create a directory called oald8 in your Downloads folder;

mkdir ~/Downloads/oald8

2) Copy the folders linux and oald8.data to your oald8 (you must substitute pathtomedia for the appropriate path!)

cd /pathtomedia/OALD8
cp -r linux oald8.data ~/Downloads/oald8
cd ~/Downloads/oald8

3) Now execute the setup file from linux/setup.data/bin/Linux/x86.

cd linux
./setup.data/bin/Linux/x86/setup

This setup will ask to install the files at ~/oald8. You should accept this way, imho.

OBSERVATION

The Oxford Advanced Learner's Dictionary tools and libraries come in 32 bits. So, at this point, if you do not have 32bits compatibility, you will receive a message like:

bash: ./setup.data/bin/Linux/x86/setup: No such file or directory

If you got this, and you are sure the file exist (try to ls it), you have to install libc6:i386, libncurses5:i386 and libstdc++6:i386.

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386

You will also need the following packages to have the oald8's libraries working:

sudo apt-get install libgtk2.0-0:i386 libpangoxft-1.0-0:i386 libpangox-1.0-0:i386

Also, you should install gtk2-engines-pixbuf:i386 and gtk2-engines-murrine:i386, since the program uses it.

sudo apt-get install gtk2-engines-pixbuf:i386 gtk2-engines-murrine:i386

If everything went right at step 3, now you have a icon in your desktop. After you hit it, the system will complain, saying it is not trusted (mark it executable and the warning will cease).

After the program launches, it will complain about the flashplayer. But you cannot install it through flashplugin-installer:i386 because it conflicts with the current flashplugin-installer.

If you run the oald8 in the terminal, you will find it wants a 32bit of version of libnssutil3.so.1d (which is part of libnss3-1d:i386) and libplc4.so.0d (which is part of libnspr4-0d:i386). But after installing these libraries, I got a segmentation fault (ftw!).

UPDATE (Some more fixes!)

Searching the web, I found this blog. That awesome guy shows how to fix the flash lib and explains the sound issue (I thought I had no sound because of the flash!).

4) He suggests to use the libflashplayer version 9r280+ (it worked in my box). You can download it from the macromedia archive, or you can try the wget command below.

cd ~/oald8/plugins
mv libflashplayer.so libflashplayer.so.old
mkdir flash9
cd flash9

wget http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp9r280_plus_archive.zip

unzip fp9r280_plus_archive.zip
tar -xvzf fp9r280_and_higher_archive/9r280/flashplayer9r280_linux.tar.gz
cp libflashplayer.so ../

5) He also explains the sound issue, and he suggests to use the padps wrapper. It is supposed to use the 32bits libpulsedsp.so, so, you need to install the libpulsedsp:i386 package.

sudo apt-get install libpulsedsp:i386

Unfortunately, the padsp script will insist to use the 64bits version of the library in the LD_PRELOAD environment variable. So, padsp is useless to this problem, and you will need to set the LD_PRELOAD by yourself before running the oald8 command. (Placing the 32bits version of the library in the 64bits folder also works... but this is an inelegant solution).

cd ~/oald8
LD_PRELOAD=/usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so ./oald8

Finally, you can automate it. I suggest you to open the run-oald8.sh file, and include (at line 68, for example) the following command:

export LD_PRELOAD=/usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so

It is still not perfect, but now I can use 95% of the tools. :D

2
  • what to do i we don't have CD only iso? – d a i s y Jan 12 '16 at 10:57
  • @MicrosoftLinux If you only have the iso file, you must mount it in a loop device. Check this link. Basically you will create an empty folder: mkdir ~/isofolder And then you will mount it (probably you will need super user privileges): mount -o loop isofile.iso ~/isofolder In this case "/pathtomedia" will be "~/isofolder". – Rafael Barreto Jan 14 '16 at 16:55
1

First install the application stardict.

sudo apt-get install stardict

Then, open the CD. Find the oald.zip file inside the linux folder and paste in the Desktop. Then extract the file. There will be oald.dict and oald.idx files.

Copy that file and Paste it on the folder

/usr/share/stardict/dic

the you can use the dictionary with stardict

** Also you can run the setup.sh file

Go to the linux folder. Then,

sudo bash setup.sh
9
  • Thanks. :) But, by dictionary files, you mean... ? which folder? – skb50bd Jul 4 '14 at 16:42
  • Can you list the files and folders inside the disk? I will pointout the one. – user308564 Jul 4 '14 at 16:47
  • cd/ folders: linux oald8.app oald8.data quickfind rr_removed files: autorun.exe autorun.inf awlphonetics3U.ttf oald.exe readme_mac.txt readme_pc.txt setup.exe – skb50bd Jul 4 '14 at 16:50
  • Inside the linux? – user308564 Jul 4 '14 at 16:52
  • comment updated – skb50bd Jul 4 '14 at 16:52
0

I am sorry about update this topic but because I had this problem and solved now I put the way here.

  1. I create an iso file from CD of oxford.

  2. Then inside the iso file exist a folder that the name of it, is linux. You should copy of it outside and there is a .sh file to install software.

Like this below picture: enter image description here

  1. Then run it: ./setup.sh that is is.

my log file:

----====== OAAD installation program ======----

You are running a x86 machine with libc5
Hit Control-C anytime to cancel this installation program.

OXFORD UNIVERSITY PRESS
SOFTWARE LICENCE


The literary material and computer software programs in this CD-ROM ("the Software") and any associated documen
tation are protected by copyright laws worldwide. The copyright is owned or licensed to Oxford University Press
 ("OUP"). 

1.      LICENCE 
OUP grants you the non-exclusive non-transferable right to use the Software on a single computer of the type sp
ecified in the packaging. You may not network the Software. 

2.      USE OF THE SOFTWARE
2.1     Without prejudice to any statutory rights so to do and except as expressly permitted by this licence, y
ou must not modify, adapt, distribute, transmit, transfer, publish, reproduce or alter any of the Software or a
ny associated documentation.
2.2     Recognising the damage to OUP's business which would flow from unauthorized use of the Software and any
 associated documentation, you will make every effort to keep the CD-ROM and associated documentation secure bo
th during the continuance of this licence and after its termination.

3.      TERMINATION 
You may terminate this licence at any time by destroying the Software and any associated documentation.  This l
icence will also terminate if you breach any of its terms.

4.      WARRANTIES
4.1     OUP warrants that the Software will be free from defects in materials and workmanship under normal use 
and will conform to the published specification for 90 days from the date you receive it.
4.2     The above warranty is in lieu of all other warranties express or implied and representations and in par
ticular but without limitation to the foregoing:
4.2.1   OUP gives no warranties and makes no representations that the Software will be suitable for any particu
lar purpose or for use under any specific conditions notwithstanding that such purpose or conditions may be kno
wn either to OUP or the dealer from whom you acquired the CD-ROM;
4.2.2   OUP accepts no responsibility for any mathematical or technical limitations of the Software;
4.2.3   OUP does not warrant that the operation of the Software will be uninterrupted or free from errors. 

5.      LIMITATION OF LIABILITY
5.1     The entire liability of OUP and its suppliers and your exclusive remedy shall at OUP's option be replac
ement of the CD-ROM disc.
5.2     Save in the case of death or personal injury, in no circumstances will OUPor its suppliers be liable fo
r any damages whatsoever (including without limitation damages for loss of data, loss of business, loss of prof
it, goodwill or any other consequential losses of any nature) arising out of the use or inability to use the So
ftware or any associated documentation.
5.3     Links to any third party websites are provided by OUP for information only and OUP disclaims any respon
sibility for any materials contained in any third website to which a link is provided.

6.      LAW 
This licence is governed by English law and the English Courts shall have jurisdiction.


Do you agree with the license? [Y/n] 
Please enter the installation path [/home/shu/oaad] 
'Application and data files' option will be installed.
'Minimal data files and application' option will be installed.
'Sound files' option will be installed.
'Permission handling' option will be installed.
'Install fonts' option will be installed.
'Install desktop shortcut' option will be installed.
Installing to /home/shu/oaad/
170492 MB available, 363 MB will be installed.

Continue install? [Y/n] 
Installing Application and data files ...
 100% - /home/shu/oaad//CD_Licence.txt
 100% - /home/shu/oaad//chrome/plugs.jar
 100% - /home/shu/oaad//chrome/en-US.jar
 /home/shu/oaad//chrome/modern.jarult/findHistoryWindow16.xpmm
 100% - /home/shu/oaad//chrome/modern.jar
 100% - /home/shu/oaad//chrome/toolkit.jar
  16% - /home/shu/oaad//chrome/comm.jare.txt
 100% - /home/shu/oaad//chrome/comm.jar
 /home/shu/oaad//chrome/oaad/skin/data/oads_arl.cssss
 /home/shu/oaad//chrome/oaad/skin/data/oads_topics.css.png.pnggng
 /home/shu/oaad//chrome/oaad/skin/img/settings/labels-bg.pngright.png.pngpng
 100% - /home/shu/oaad//chrome/oaad/skin/oad/img/popups-btn.pnglex-bg.png
 100% - /home/shu/oaad//chrome/oaad/skin/oad/img/interface/toolbar-btn.pngnggggg
 /home/shu/oaad//chrome/oaad/skin/global/arrow/arrow-dn-sharp.giff.gifgifg.png
 100% - /home/shu/oaad//chrome/oaad/skin/oaad/img/popups-btn.pnglex-bg.pngif

 100% - /home/shu/oaad//chrome/oaad/skin/oaad/img/interface/toolbar-btn.pngnggggg
 100% - /home/shu/oaad//chrome/oaad/skin/obad/img/popups-btn.pnglex-bg.pngg.png
 /home/shu/oaad//chrome/oaad/skin/obad/img/global/scrollbar/spacer1-vrt.gif
 100% - /home/shu/oaad//chrome/oaad/skin/obad/img/interface/toolbar-btn.pngnggggg
 100% - /home/shu/oaad//chrome/oaad/content/flash/word_family_negative.swfg.png
 100% - /home/shu/oaad//chrome/oaad/content/flash/jumbledwords.swf
 100% - /home/shu/oaad//chrome/oaad/content/flash/listentype.swfp.xmlxmlmlxmll
 100% - /home/shu/oaad//chrome/oaad/content/flash/word_forms.swf
 100% - /home/shu/oaad//chrome/oaad/content/flash/word_definitions.swf
 100% - /home/shu/oaad//chrome/oaad/content/flash/word_family.swf
 100% - /home/shu/oaad//chrome/oaad/content/flash/which_words.swfswfopriate.flawfns.swf.fla
 100% - /home/shu/oaad//chrome/oaad/content/flash/wwtv.swfpp.xmlxmlmlxmll
 100% - /home/shu/oaad//chrome/oaad/content/flash/opposites_synonyms.swf
 100% - /home/shu/oaad//chrome/oaad/content/flash/wdtv.swf
 100% - /home/shu/oaad//chrome/oaad/content/flash/images/piecharts.jpg
 100% - /home/shu/oaad//chrome/oaad/content/flash/ald8ex.swf
 100% - /home/shu/oaad//chrome/oaad/content/flash/words_in_context.swf
 100% - /home/shu/oaad//chrome/oaad/content/flash/iwriter.swf
 100% - /home/shu/oaad//chrome/oaad/content/flash/prepositions.swf.mp333
 100% - /home/shu/oaad//chrome/inspector.jarntents.rdfrface.xulxml
 100% - /home/shu/oaad//components/libhtmlpars.so
 100% - /home/shu/oaad//components/libuconv.soptso
 100% - /home/shu/oaad//components/libnecko.sotso
 100% - /home/shu/oaad//components/libwidget_gtk2.so
 100% - /home/shu/oaad//components/libtransformiix.so
 100% - /home/shu/oaad//components/libimglib2.sootener.js
 100% - /home/shu/oaad//components/libxpconnect.so.so
 100% - /home/shu/oaad//components/libdocshell.sopto
 100% - /home/shu/oaad//components/libappcomps.som.so
 100% - /home/shu/oaad//components/libgfxps.soscom.so
 100% - /home/shu/oaad//components/libmork.so
 100% - /home/shu/oaad//components/libgfx_gtk.so
 100% - /home/shu/oaad//components/libeditor.soxpcom.so
 100% - /home/shu/oaad//components/libpipnss.sosptt
 100% - /home/shu/oaad//components/libi18n.sorxpcom.so
 100% - /home/shu/oaad//components/libgklayout.soso
 100% - /home/shu/oaad//components/libxpinstall.sopt
 100% - /home/shu/oaad//libSDL-1.2.so.0s.jss.jsfrdfome-example.csss
 100% - /home/shu/oaad//libaspell.so.15
 100% - /home/shu/oaad//libmozjs.so
 100% - /home/shu/oaad//libnspr4.so
 100% - /home/shu/oaad//libnss3.so
 100% - /home/shu/oaad//libnssckbi.so
 100% - /home/shu/oaad//libsmime3.so.so
 100% - /home/shu/oaad//libsmpeg-0.4.so.0
 100% - /home/shu/oaad//libsoftokn3.so
 100% - /home/shu/oaad//libssl3.so
 100% - /home/shu/oaad//libstdc++.so.5
 100% - /home/shu/oaad//libxpcom_core.so
 100% - /home/shu/oaad//plugins/libflashplayer.so
 100% - /home/shu/oaad//./icon.xpmkfindbecursor.so.soifiesrties
 100% - /home/shu/oaad//./splash.xpm
 Running script
chdir(push: ../oaad.data): No such file or directory
loki_setup: 2 Unable to find file 'fs.skn' in '/home/shu/Desktop/linux'
chdir(push: ../oaad.data): No such file or directory
loki_setup: 2 Unable to find file 'pic.skn' in '/home/shu/Desktop/linux'
chdir(push: ../oaad.data): No such file or directory
loki_setup: 2 Unable to find file 'resources.skn' in '/home/shu/Desktop/linux'
chdir(push: ../oaad.data): No such file or directory
loki_setup: 2 Unable to find file 'thumb.skn' in '/home/shu/Desktop/linux'
chdir(push: ../oaad.data): No such file or directory
loki_setup: 2 Unable to find file 'topics.skn' in '/home/shu/Desktop/linux'
Installing Minimal data files and application ...
 100% - /home/shu/oaad//oaad.data/topics.jar
chdir(push: ../oaad.data): No such file or directory
loki_setup: 2 Unable to find file 'us_pron.skn' in '/home/shu/Desktop/linux'
Installing Sound files ...
 Fixing data
 Install fonts

 Install desktop shortcut

Installation complete.

After installing you will have icon of software in your desktop that name of it will be oaad.desktop that you can not run it because it has not permission.

  1. Now by your terminal set permission of it: chmod +x aood.desktop

You should now see the icon of it

enter image description here

But if you run it, because the software has not date-base, nothing to show to you.
Then you should mount the original iso as a CD-ROM so the software can use it.
I try mount -t iso9660 -o loop but it is failure.

  1. Instead of it you can install CDemu that it is Virtual CD/DVD Drive Then :

    sudo add-apt-repository ppa:cdemu/ppa
    sudo apt-get update
    sudo apt-get install gcdemu cdemu-client
    

After that run it and mount your iso file.
Now, if you run the icon of OAAD you will have it :)

enter image description here

Ubuntu 16.04 LTS | x86

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.