0

I'm newbie to Ubuntu and I'm using Ubuntu 14.04 (dual booted with Windows 7). Last few days it was working fine but from today my problem as follow as,

FIREFOX NOT WORKING IN UBUNTU

  • Note: I had firefox only. Not anymore chrome etc...

Its says only,

SERVER NOT FOUND

But I don't see any network connecting problem in Windows 7

Note:

1. using Ethernet.
2. No proxey.
3. Manual method.
4. IPv4 settings.  
5. Wired connection.

update:

ip         -> 198.168.20.93   
netmask    -> 255.255.255.0   
gateway    ->198.168.20.14
dnsserver  ->198.168.20.14

How can I resolve my internet issue?

UPDATE 1:

ubuntu@P3-SD1:~$ ifconfig

eth0      Link encap:Ethernet  HWaddr 00:1c:c0:80:19:d3  
          inet addr:198.168.20.93  Bcast:198.168.20.255  Mask:255.255.255.0
          inet6 addr: fe80::21c:c0ff:fe80:19d3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:157600 errors:1865 dropped:2455 overruns:0 frame:1865
          TX packets:6437 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:12506428 (12.5 MB)  TX bytes:349342 (349.3 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:11260 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11260 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:897196 (897.1 KB)  TX bytes:897196 (897.1 KB)

ubuntu@P3-SD1:~$ route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         198.168.20.14   0.0.0.0         UG    0      0        0 eth0
198.168.20.0    0.0.0.0         255.255.255.0   U     1      0        0 eth0

ubuntu@P3-SD1:~$ cat /etc/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1

ubuntu@P3-SD1:~$ ping www.google.com

ping: unknown host www.google.com

UPDATE 2:

ubuntu@P3-SD1:~$ cat /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
12
  • Did you actually enter .xx in the IP address? That would not be a valid address. Then, 255.255.255.0 is not a valid gateway. In this place you should enter the IP address of your router. In this case, the netmask should be 255.255.255.0. Also, when applying the manual network settings, I think you forgot to enter DNS settings. You need to enter the IP address of at least one (preferably two) DNS servers.
    – Jos
    Jul 4 '14 at 11:29
  • @Jos, thanks for very first replay, Dns Server is add as same as the netmask..
    – RGK
    Jul 4 '14 at 11:31
  • @Jos, pls check my update details,...
    – RGK
    Jul 4 '14 at 11:38
  • Hi! Can I please ask for the output of 1. ifconfig, 2. route -n , 3. cat /etc/resolv.conf & last 4. ping google.com. ** Edit your question and post those information please. Before, that make sure your firefox settings are been set to use auto detect on pictures as seen in this answer. This is to show you where to find the proxy settings but not doing the same as what mentioned there.
    – AzkerM
    Jul 4 '14 at 11:50
  • When you refer to manual method. Are you referring to Firefox connection settings. If so then with no proxy you should have Firefox set to use system or no proxy.
    – StallionSA
    Jul 4 '14 at 12:00
2

I suppose that these addresses starting with 198 are wrong. Try to enter 192 instead of 198.

0
0

switch the values of gateway and netmask (are these the same as in windows?).

ip        -> 198.168.20.93
netmask   -> 255.255.255.0 
gateway   -> 198.168.20.01 (router address)
dnsserver -> 198.168.20.01 (router address, also try 8.8.8.8)

Have you tried Automatic (DHCP)?

1
  • sorry, its not working same result in DHCP
    – RGK
    Jul 4 '14 at 12:24
0

Finally user300458 finding right one:

ubuntu@P3-SD1:~$ cat /etc/resolv.conf

but @AzkerM telling some use full and some change with got the solution,

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1

ubuntu@P3-SD1:~$ cat /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto eth0
iface eth0 inet loopback
1
  • my bad!! 198 looks like 192 for me.. that got me confusing but still if your router was issuing such serious that would've been... This is why I prefer the exact information without editing is posted. So, we will get a better understanding.
    – AzkerM
    Jul 4 '14 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.