0

Alright, so I'm having this very odd problem, I've tried everything I know and just can't seem to figure out whats causing it. I'm on Xubuntu 14.04.

Randomly my usb wifi dongle will, for lack of a better word, "hang". The flashing LED on it goes stable, network manager reports that I'm still connected to the internet, but I am unable to load webpages. Oddly however is that whenever this occurs, qbittorrent freezes as well and refuses to respond to any clicks or input.

As soon as I unplug my dongle, qbittorrent immediately unfreezes like there never was a problem. Upon replugging the dongle it connects flawlessly to my network.

I noticed this issue started just a little bit after i installed qbittorent, I'm using qbittorent 3.1.9.2 direct from the PPA, I tried downgrading to 3.1.8 from the official repo but to no avail. iwonfig output

wlan0 IEEE 802.11bgn ESSID:"TP-LINK"
Mode:Managed Frequency:2.437 GHz Access Point: 00:1D:0F:F8:7B:12
Bit Rate=54 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off Power Management:off Link Quality=58/70 Signal level=-52 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:7 Invalid misc:132 Missed beacon:0

sudo lshw -C network output

      *-network               
       description: Ethernet interface
       product: 82579V Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 05
       serial: 38:60:77:9c:e5:13
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k firmware=0.13-4 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:42 memory:fe400000-fe41ffff memory:fe428000-fe428fff ioport:f080(size=32)
  *-network
       description: Wireless interface
       physical id: 1
       bus info: usb@1:1.2
       logical name: wlan0
       serial: f8:d1:11:09:d2:3b
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=ath9k_htc driverversion=3.13.0-30-generic firmware=1.3 ip=192.168.2.102 link=yes multicast=yes wireless=IEEE 802.11bgn

lsusb

Bus 001 Device 006: ID 0cf3:7015 Atheros Communications, Inc. TP-Link TL-WN821N v3 802.11n [Atheros AR7010+AR9287]

Also when my dongle is in this hanged state, and attempt at ping or inputting command iwconfig will result in the output never coming, seemingly taking forever, as soon as the dongle is unplugged however, the output to these commands suddenly appears.

0

I believe this is a problem related to overheating. I have the same dongle and I experienced the same problem from times to times, specially when doing some network intensive tasks (like downloading torrents or updating the system).

To solve this, you'll need to lower the transmission power (TX-Power in iwconfig). For instance, iwconfig wlan0 txpower 12 will lower the transmission power of wlan0 from 20dB to 12dB.

This is not permanent, though. You'll have to configure your system to run this command on every boot or every time a connection is made (I'm using another distro right now, so I don't know exactly how to do this on Ubuntu, sorry).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.