1

The Canon printers under Linux have been constant sources of pain. The issue of not being able to print using a Canon printer has been discussed a number of times.

(Actually, the issue of Canon printer pops up in this forum now and then and they are too many to enumerate).

Anyway, so far as my experience goes in the last two years, there has never been a definite diagnostic process chalked out. See also this question.

Yesterday, I had an strange experience which though may seem far fetched, I feel it necessary to report here since it may be useful to others. Moreover, I want to understand what really happened here.

Last night, in the late hours, my Canon LBP6000 suddenly stopped printing. None of the empirical practices undertaken worked.

Then I started thinking about the recent changes made so far in my machine. The only one I could find is installing a cups pdf printer. Out of desperation, I removed this printer (apt-get purge), rebooted my machine, and the Canon printer started working again.

Now, the question is, do you really think there is a connection between the pdf printer and the Canon printer where the former may make the latter stop printing? Any technical details which can be included in the answer may become helpful to the frustrated community of Canon printer owners under Linux.

UPDATE

I have tested by re-adding the cups-pdf printer, and the results look inconclusive.

  • 1
    Installing the cups-pdf printer marks it as default? It can't be this simple can it? – Goksu Jul 3 '14 at 23:40
  • @Goksu I am afraid not. I specifically tried to print from the Canon printer, not the pdf printer. Moreover, the Canon printer had been set as the default one and it remained as default after installation of the pdf printer. So, it not that simple. Do you want to add any technical details in support of your comment? – Masroor Jul 4 '14 at 9:22
  • 1
    I would look at your /var/lib/dpkg/info/cups.config now, while Canon is working, then re-install cups-pdf and see what is changed, if anything. – RCF Jul 6 '14 at 17:01
  • And also, check here /usr/local/etc/cups/cupsd.conf – RCF Jul 6 '14 at 17:08
  • @RCF-U14.04 The files are too large to be included here. Please get them from here and here. As is shown by the diff command, there is not difference between the two. – Masroor Jul 6 '14 at 17:10
1

Chances are that the cups pdf printer installed a file that doesn't work well with your cups and/or the Canon drivers.

Install package cups-pdf again and start moving files to a different directory and restarting cups until printing starts working again. I would start with these 2 files:

/etc/cups/cups-pdf.conf
/usr/lib/cups/backend/cups-pdf

To list all files in package cups-pdf use dpkg -L cups-pdf.

Chances are that it is not Canon to blame this time (for a change), the bug looks like to be in package cups-pdf. Once you find the offending file please consider filing a bug report.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.