I downloaded freeverb.tar.gz which contains a plugin library (freeverb.so) for Audacity.

I extracted the .tar.gz file to my downloads folder but I don't know what to do next. There is no Readme file or any other info contained in the .tar.gz file, just freeverb.so

Can you advise me how to get the freeverb.so installed into the correct folder for Audacity to pick it up?

3 Answers 3


According to ubuntu manual:

ldconfig creates, updates, and removes the necessary links and cache (for use by the run-time linker, ld.so) to the most recent shared libraries found in the directories specified on the command line, in the file /etc/ld.so.conf, and in the trusted directories (/usr/lib and /lib).

So, assuming that freeverb.so is located in /home/yourUser/Download directory (folder), create folder in your home:

mkdir /home/yourUser/myLibrary

and copy freeVerb.so library:

cp /home/yourUser/Download/freeverb.so /home/yourUser/myLibrary

create a simple file freeverb.conf like this:

echo "/home/yourUser/myLibrary" > freeverb.conf

Add you configuration file freeverb.conf in /etc/ld.so.conf.d directory (in this directory you can find files as example)

sudo cp freeverb.conf /etc/ld.so.conf.d

Run ldconfig in order to configure dynamic linker run-time bindings.

sudo ldconfig

If /etc/ld.so.conf.d doesn't exists, you can add your path at the end of /etc/ld.so.conf file.

At the end, if all went well, you can remove unnecessary file:

rm freeverb.conf
rm /home/yourUser/Download/freeverb.so
  • Hi Letizia thank you for answering my question. This is how far I have got - I created freeverb.conf file in text editor containing the path to my freeverb.so file but when I try to save it to /etc/ld.so.conf.d directory I get error message 'Do not have permission to save to /etc/ld.so.conf.d directory' when I use UI. Could you tell me please what is the sudo command I need to use in the command line to add this file? I know this is basic but I have only come over from Windows and this is all new to me, many thanks, Dave
    – DaveyT
    Jul 4, 2014 at 8:35
  • I updated the answer
    – Lety
    Jul 4, 2014 at 8:50
  • Hi Letizia,dt@laptop:~$ sudo cp freeverb.conf /etc/ld.so.conf.d [sudo] password for dt: cp: cannot stat `freeverb.conf': No such file or directory
    – DaveyT
    Jul 5, 2014 at 7:44
  • I updated the answer
    – Lety
    Jul 6, 2014 at 14:35
  • Hi Letizia, removed unnecessary freeverb.so file, I now somehow have a locked freeverb.so directory within my Home directory, I tried to remove it with -r /home/user/freeverb.so but I get error message '-r : command not found I also tried -R and --r
    – DaveyT
    Jul 9, 2014 at 10:19

The simple approach is to put the file in /usr/local/lib, chown the file to root:root, and chmod it to 755.

However, managing system files manually is not something I would personally recommend, so if possible I would search for a prebuilt .deb file for your particular version of Ubuntu.


You can install the package containing the library in a clean system (such as reference docker container with the same system) and then copy the missing shared library (as reported during failed run attempts) from the installed location (such as /lib/x86_64-linux-gnu/) to exactly the same location in the target system or container.

Be warned that multiple additional packages may need to be installed to extract all the necessary dependencies (a common problem with so-called "distroless" containers). It is therefore best to list all dependencies using ldd to avoid an iterative process.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .