6

I'm trying to install the google talk plugin on Ubuntu 14.04. I've been following this guide:

http://www.ubuntuupdates.org/ppa/google_talk_plugin

When I do the last step, sudo apt-get install google-talkplugin, I get the following error:

Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/repository.spotify.com_dists_stable_non-free_i18n_Translation-en%5fUS
E: The package lists or status file could not be parsed or opened.

This doesn't make sense. What does Spotify have to do with installing Google Talk?

3
10

Spotify is having some problem with their repository URL being incorrectly resolved on DNS level. As a temporary solution replace the URL in your repositories list. By default, i.e. when installed from official Spotify instructions for Ubuntu users, you'll find it in /etc/apt/sources.list.d/spotify.list. For different distributions the line might be in /etc/apt/sources.list or in any of the files under /etc/apt/sources.list.d/. Change it to read as follows (mark the -origin part):

deb http://repository-origin.spotify.com stable non-free

Afterwards clean the apt lists cache and update as usual:

sudo rm /var/lib/apt/lists/*
sudo apt-get update && sudo apt-get -y upgrade

It should work.

2
  • Thanks! This worked. For some reason I didn't have a directory called sources.list.s, but I changed the one that was just in sources.list and that worked. – user300224 Jul 5 '14 at 6:48
  • 1
    similar to the answer provided here: link Remove the spotify repository from software sources , then add spotify source with origin in name In terminal sudo add-apt-repository -r "deb http://repository.spotify.com stable non-free" sudo add-apt-repository "deb http://repository-origin.spotify.com stable non-free" sudo rm /var/lib/apt/lists/* -vf sudo apt-get update sudo apt-get upgrade – Jacques MALAPRADE Aug 3 '14 at 13:07
2

I've had the same issue - looks like Spotify's repository is fouled up, which makes the rest of Ubuntu upset. Tried copying /var/lib/dpkg/status and all the usual stuff, but still got complaints.

In the end, solved this by going to Software & Updates > Other software and unchecking the Spotify repository. Ran Software Updater again and it downloaded everything perfectly. I think Spotify have messed up on their end given that this is so widespread. Disable the Spotify repo, give it a day or two and see how it is then.

The search functionality seems to stop working after this, but I'm using the Web Player for the time being so no problem...

-1

The solution from Cyprian works great, apart from the line with rm which should be:

sudo rm /var/lib/apt/lists/* -vf
2
  • 1
    Why? -v is verbose mode to print each and every removed file, it's unnecessary. – cprn Jul 4 '14 at 13:33
  • 2
    the -f flag does something, but is entirely unnecessary when working as root. – Gx1sptDTDa Jul 6 '14 at 11:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.