Hi while trying to get the drivers for my "EDIMAX AC600 Dual-Band High Gain Wi-Fi USB Adapter" I run into the following problem:

After sudo apt-get install build-essential

and cd /home/"USERNAME"

I try to tar vxzf rtl8812AU_linux_v4.2.0_6952.20130315.tar.gz

but I get:

tar (child): rtl8812AU_linux_v4.2.0_6952.20130315.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now

as result

I can't find the folder where it is supossed to be, the sudo apt-get doesn't show me where it put it.

I am Running Xubuntu and I'm totally new to it, borrowed that laptop a week ago for my travels.

Thank your for you attention


Simply copy and paste each command:

sudo apt-get install build-essential git
git clone https://github.com/gnab/rtl8812au.git
cd rtl8812au
sudo make install
sudo modprobe 8812au

You should be all set.

You have compiled the driver for your current running kernel only. When Update Manager installs a later one, also known as linux-image, re-compile:

cd ~/rtl8812au
make clean
sudo make install
sudo modprobe 8812au

Glad it's working!

  • 1
    Please see my edit above and if my answer has been helpful, please accept it. – chili555 Jul 3 '14 at 15:39

Now this driver has been added to Ubuntu repositories.

It can be installed to Ubuntu 15.10 and 16.04 by running

sudo apt-get install rtl8812au-dkms

The current version is 4.3.8.


Special note! :D I have D-Link AC1200 USB adapter. It's a Revision D tho!!! So I kept digging and digging... turns out, revision C had a different chip, than mine! So for those of you digging that can't get yours working,

OR if you know you have a Realtek RTL8812BU or RTL8822BU chipset, then try the following 1 line at a time in your command prompt. Worked for me and I'm so stoked right now! :D :) I had to dig and dig tho, so I thought I would drop this gem here since all my searches for DWA 182 d1 led me here at one point or another. Hope this helps someone. :)

sudo apt update
sudo apt install -y git
git clone https://github.com/EntropicEffect/rtl8822bu.git
cd rtl8822bu
sudo make install
sudo modprobe 88x2bu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.