Okay hi guys, I've tried multiple solutions to other (similar) problems posted here but sadly they don't yield anything good :(

My stuff:

  • Acer Aspire V3-471G
  • Intel Core i5-3210M
  • Currently using 14.04 32bit

(My laptop worked fine with 12.10 and 13.04 32bit)

My graphic cards:

  • Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
  • NVIDIA Corporation GF108M [GeForce GT 630M] (rev a1)

(I got the graphic cards info from sudo lspci | grep VGA)

I installed from a live usb. I've done it countless times before.

Though this time, when the live usb booted up I got a "playlist update failed" error. So I closed everything and did some research. After all that, I booted the usb, pressed any key at the "Keyboard and Man" page and I accessed the boot options. I then activated the "nomodereset" option and selected the "Install Ubuntu"option. Then everything went smoothly. Everything installed well and all that. Yay.

The installation completed and I ended up in the login screen, I entered my password and waited a minute or so from the delay and everything loaded quite fine. So far so good.

Then I started doing the usual stuff. Updating, Upgrading, loading repositories, and installing what I wanted.

One of the things I installed was VLC because I like watching music videos, and anime, and movies and all that. I also installed Steam because I play DotA 2 a lot.

Now the it was only then that I saw multiple problems.

  • My system lags when I resize any window.
  • VLC lags when playing videos.
  • DotA 2 interface does not display correctly.
  • Also when I do any of these 3 (or anything similar) my CPU performance spikes despite having four cores working

So of course I pinpointed the problem to one of my graphic cards. It can't be intel cause I never had problem with it so it must be Nvidia (also it seems to be very notorious among ubuntu users)

Most of the forums/questions/answers/tutorials I've seen pinpoint the drivers being used as the problem since Ubuntu forces me to use the open source Nouveau drivers which basically doesn't work well for Nvidia. So I prompted to get the proprietary Nvidia drivers.

What could go wrong right?

Well I was able to find out that the driver I need is the 331.79 So I downloaded it and followed instructions.

I booted to tty. ran the sh *insert nvidia installer here.run* file ran the xconfig thingy so that my laptop will use the nvidia drivers and rebooted

Now of course I'm calm because my problem is supposedly solved.

Apparently not, after loggin in at the login page, I just got the wallpaper and my cursor. Nothing else. Another problem great.

Anyway you get the gist of my problem hopefully.

I've tried so many stuff like using bumblebee, nvidia-prime, etc. I just want my nvidia chip to work so help please? :D

Oh right now the solution I'm using is installing 32bit instead of 64bit (Yeah I tried 64bit first since my hardware is supposed to be able to handle it) I haven't tried installing the nvidia driver yet but I'll update soon.

Sorry for my lengthy question but I just wanted to put everything on the table hahaha thanks :D

closed as off-topic by Zanna, David Foerster, Eric Carvalho, TheWanderer, amc Nov 18 '16 at 5:50

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Zanna, David Foerster, Eric Carvalho, TheWanderer, amc
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I am having the same problem (GeForce GTX650 1024MB)! ... Everything worked fine from 12.04 to 13.04.... I tried everything I could to move to 14.04 and no success... I am stuck at 12.04 right now... - The Drivers on the Ubuntu Repos are the best ones! - Try tweaking the Xorg.config after installing NVIDIA Proprietary Drivers to, maybe, force the output to Nvidia (After averything I have done the Xorg.config manually editing is the one thing that came as close to a solution) .... P.S. The problem seems to be on the newest versions XSERVER + GTX 6 Series, since I also tried different di – Raphael Sanches Jul 28 '14 at 18:23

One of the other answers led me to a workaround solution for my T61 on Ubuntu 16.04. I was getting giant black-and-white zig-zag lines on regular boot but with the recovery boot was fine.

I ended up not having a xorg.conf file (here the 'x' was not upper-case); instead, I found an 'emergency' one and copied that in -- seems to work!

sudo cp /etc/X11/xorg.conf.failsafe  /usr/share/X11/xorg.conf.d/xorg.conf

Not the answer you're looking for? Browse other questions tagged or ask your own question.