Occasionally my lock screen does this:

No password input

That makes logging in difficult. Restarting Unity kind of works, sometimes only a reboot will fix it. My video card is a Sapphire Radeon HD 6870 with dual displays using the open drivers.

  • 4
    This might be a bug. Take a look at bugs.launchpad.net/ubuntu/+source/unity/+bug/1311316 – Mitch Jul 3 '14 at 8:35
  • Had the same problem, mostly occuring when training neural networks using Caffe. unity --replace makes the login screen go away, but everything else seems corrupted. So I still had to reboot :( – mcExchange Nov 10 '15 at 9:00

Reloading unity restores the password input on the login screen for me (Ubuntu 14.04 with a Nvidia GPU).

  1. Switch to an alternate terminal using Ctrl+Alt+F1.

  2. Reload unity with:

    nohup unity --replace &
  3. Switch back to your graphical terminal using Ctrl+Alt+F7. You may have to wait several seconds if you see a black screen.

Unity sort of works after this but you can at least save your work in progress:

  • The compiz grid plugin seems to think multiple monitors are now a single monitor.

  • The global menu bar no longer works.

  • Menus in window title bars no longer work (if enabled).

  • Custom global keyboard shortcuts don't work.

| improve this answer | |
  • Note: In more recent versions, the --replace option is deprecated. :( – BlueBomber Feb 13 '15 at 19:06
  • This worked to recover my desktop but killed all my running task! I think I may have to part with Unity as it is not reliable. – Steven C. Howell Jun 23 '15 at 12:33
  • This has the strange side-effect of making me enter my password twice to log in. (14.04) – ashes999 Jul 25 '15 at 19:14
  • If nothing else works, try entering your username login in ALL LOWERCASE. I pulled my hair out before finally coming to this solution! – wesf90 Oct 20 '15 at 18:55
  • This works, albeit with the really hilarious side-effect of requiring me to enter my password twice whenever I unlock. As you said, sort of works, and rebooting is probably the best way to go. – ashes999 May 7 '17 at 12:46

I had the same problem on an HP with Radeon 6370 graphics. I'm still using open source graphics, but I'm using the versions that came from the oibaf repository - they are a little 'edgier' than the stock open source, but not as edgy as xorg-edgers.

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt-get upgrade

installs the drivers

sudo apt-get install ppa-purge
sudo ppa-purge ppa:oibaf/graphics-drivers

removes the drivers.

| improve this answer | |
  • Tried this one, and it didn't seem to work. Did I have to reboot after installing the new drivers? – Andy Gaskell Jul 5 '14 at 4:20
  • Yes you would need to reboot. – Charles Green Jul 5 '14 at 14:20

open terminal

reset the unity

$ unity-reset
$ setsid unity 

if that didnt workout try to re-install the unity & the desktop

$ sudo apt-get autoremove ubuntu-desktop 
$ sudo apt-get autoremove unity 
$ sudo apt-get update 
$ sudo apt-get install unity
$ sudo apt-get install unity-2d 
$ sudo apt-get install ubuntu-desktop 
$ sudo shutdown -r

now install the ati driver

$ sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
$ sudo apt-get update
$ sudo apt-get install fglrx gksu
$ sudo amdconfig --initial && sudo shutdown -r

after the reboot
u can run the driver buy ALT + F2
copy & past this

gksu amdcccle
| improve this answer | |

This can be worked around without losing your session by:

  1. Switch to a tty (e.g. Ctrl+Alt+F1)
  2. Log in
  3. Run: sudo loginctl unlock-sessions
  4. Switch back to the Desktop: Ctrl+Alt+F7 (or F8).

From the bug report fori this issue and this answer to a similar question

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.