As you can see, this blank Commands lens is now on my Unity Launcher, without installing any related software. It launches the Run a command dialog (like Alt+F2) but it has no icon...how did it get there? Is it related to recent Unity updates? Or maybe to some application? If so, how can I get rid of it, since there's no file under /usr/share/unity/places? Thanks for your time!

The mysterious Commands lens

  • Can you check if you have a mangled file somewhere in /usr/share/unity/places? – Jorge Castro Jun 17 '11 at 16:10
  • No files whatsoever there, aisde from applications.place and files.place. By the way, I just found out that the ghost lens can be replaced above or below the other lenses, but not above the worskpace switcher nor the launchers. – Tigull Jun 18 '11 at 12:38
  • I showed this problem to some unity devs and they've never seen this before, if you could file a bug on this problem it would be great: askubuntu.com/questions/5121/how-do-i-report-a-bug – Jorge Castro Jun 18 '11 at 16:48

What it is, is a bug. File a report on launchpad.net and gain some Karma. Attach that screenshot. :)

As for how you get rid of it, if you press alt+f2 and run compiz --replace, then I'm fairly sure it'll go away.

As a wild guess, I'd say "Commands" is the default label for launcher quicklists and that somehow, an empty and unconfigured launcher entry has been created for some reason. But it's a wild guess and it might very well be entirely wrong.

| improve this answer | |

I experienced something similar. I tried to add a launchericon to the launcher, which was executing the xkill command. It worked but instead of a symbol there was a blank space, however by rightclicking and clicking keep in the launcher I could remover this issue.

| improve this answer | |
  • I should have showed it in the picture, but there isn't any option nor quicklist when right clicking the "ghost" icon. There' s just a Commands options which launches the dialog exactly the same way as a left-click does. – Tigull Jun 16 '11 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.