I have enabled icons in menus, and most of them show up well (folder icons, file icons, save icons, etc.). But whenever an app tries to use an icon specific to itself, such as GIMP, it replaces that icon with the app icon, so that when I look at a menu in GIMP, I see most of the time just icons of GIMP's logo (that seems to be the only problem; the text is fine). I thought this was proper to GIMP, but I also noticed it happening on AbiWord.

Thankfully, as I said, it's not for all icons. But it still bugs me. Why is it so?

Here is a screenshot of a menu in GIMP:

A menu in GIMP, in Unity.

I am using Ubuntu 11.04 Natty Narwhal, with Unity desktop (the problem also occurs on the Classic desktop, if I remember correctly).

EDIT: This does NOT occur on the Classic desktop; only in Unity.


@Lyrositor, have you tried the following:

gconftool --set /desktop/gnome/interface/menus_has_icons --type bool true
gconftool --set /desktop/gnome/interface/buttons_have_icons --type bool true

I would be curious to know if this helps mitigate the issue with the menu icons.

  • I had already enabled icons through Ubuntu Tweak, so this did absolutely nothing. As I said, I can see standard icons, just not the application icons. Applications with built-on icon sets, such as LibreOffice, seem to work however. – Lyrositor Jun 21 '11 at 14:02
  • Thanks for this. While it didn't solve the OP's issue, it worked for me with Firefox. – Chris Granger Aug 7 '11 at 18:46

"gconftool ......" did not helped me. Installation of "Ubuntu Tweaks" and manual change for settings work fine:

  1. install "GNOME Tweak Tool"

    sudo apt-get install gnome-tweak-tool

    should show up as "Advanced Settings" in the Ubuntu menu.

  2. Select Tab "Theme", and make "Menu have icons" = "On" and "Button have icons" = "On"

    No logout in necessary. Icons appear in Nautilus menu and Writer menu and ....


It is global menu bug. Just disable it to have normal icons in Gimp, Inkscape etc.

  • 5
    ... if its a bug - please reference the bug report. – fossfreedom Feb 21 '12 at 14:44
  • 1
    This is not a bug. – RolandiXor Sep 28 '12 at 3:16
  • @Roland Taylor So that is it? Why I can't see normal icons in gtk2 apps like Inkscape and Gimp in global menu? bugs.launchpad.net/ubuntu/+source/inkscape/+bug/775702 – KEIII Nov 2 '12 at 16:31
  • @KEIII it's not a bug. What happened was that GNOME transitioned (rather poorly) from using icons in menus and buttons and that's why it doesn't work in some apps but works in others. – RolandiXor Nov 3 '12 at 1:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.