1

I have 2 computers running Kubuntu 14.04 64 bit and this Brother printer: MFC-J6910DW

The printer has wifi capabilities. I've set up a fixed IP address: 192.168.1.191.
The router address is 191.168.1.1

I've installed the drivers in both computers. Both of them can do successfully: 192.168.1.1
I connect specifying these data manually in the KDE wizard for adding a new remote printer:

  • lpr://192.168.1.131
  • The queue is BINARY_P1
  • I specify the right driver, supplied by Brother.

In computer A, I can print successfully, whereas in Computer B, when I try to print something, it appears in the queue as a job, and it says it is completed, but never prints. No error message appears.

Why can I not print in computer B?
How can I diagnose the problem?

Here is the official page for Brother printers in Linux

2

This has worked for me following the tip of technical support of Brother:

I would recommend removing the printer driver and re-installing using our install utility that will automate the download/install process. You may access this installation utility at the following location.

After running the Brother install utility, I was offered these choices:

0: ipp14
1: socket
2: https
3: ipp
4: ipps
5: lpd
6: http
7: serial:/dev/ttyS0?baud=115200
8: smb
9: hp
10: parallel:/dev/lp0
11: hpfax
12 (I): Specify IP address.
13 (A): Auto. (usb://dev/usblp0)

At first, I tried number 12 and didn't work. So, I created another printer with the URI: lpr://192.168.1.131 instead of socket://192.168.1.131 and it works now. :-)

  • 2
    How is this different than the way you tried in question? – Anwar Nov 15 '16 at 8:07
  • I've used the install utility from Brother, instead of specifying the data manually. – david.perez Nov 15 '16 at 10:16
  • 1
    You didn't say in your question that you used manual settings. Please clear the question and answer. As I can see, you used same lpr prototcol in both. – Anwar Nov 15 '16 at 10:31
  • I've made more clear both the question and the answer. – david.perez Nov 15 '16 at 15:31
1

Had a similar problem with Brother HL-L2352DW on Ubuntu 17.10 . It started working when I installed it with Brother install utility with LPD uri (lpd://BRW2C6FC9312B2C/BINARY_P1) and after some turning off and on the printer and the router. I've have also set the static IP for the printer on my router. PS. It started working after some idle time (like 10 minutes) - it printed the installation test page after that time...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.