2

I have downloaded Ubuntu 14.04 and I have tried it (without installing it).

I connected to the internet via DSL and I tried to surf. When I tried to go to an https:// site, it showed me the error message "This Connection is Untrusted" with the following Technical Details (for example):

mail.google.com uses an invalid security certificate. The certificate is not trusted because no issuer chain was provided. (Error code: sec_error_unknown_issuer)

This also happens in Chrome and the browser of Ubuntu, but it doesn't happen in Windows.

EDIT - My certificate(when trying login to gmail(on 6 July)):

accounts.google.com
Identity: accounts.google.com
Verified by: www.netspark.com
Expires: 09/02/2014

Subject Name
C (Country):    US
ST (State): California
L (Locality):   Mountain View
O (Organization):   Google Inc
CN (Common Name):   accounts.google.com
Issuer Name
C (Country):    US
ST (State): New York
L (Locality):   New York
O (Organization):   NetSpark
OU (Organizational Unit):   NetSpark Development
CN (Common Name):   www.netspark.com
EMAIL (Email Address):  support@netspark.com
Issued Certificate
Version:    3
Serial Number:  5D BB B0 22 36 A8 00 00
Not Valid Before:   2014-06-04
Not Valid After:    2014-09-02
Certificate Fingerprints
SHA1:   4D 5B C4 64 A0 9B 81 10 4E 73 CA 6C 25 81 FA D6 6C 91 1C 1A
MD5:    B0 87 85 F2 77 8C DC E3 E8 88 60 01 AA 54 50 78
Public Key Info
Key Algorithm:  RSA
Key Parameters: 05 00
Key Size:   1024
Key SHA1 Fingerprint:   7C 55 41 DE C3 FF C0 21 8D 46 96 B4 17 C0 F4 EF DF 45 07 D2
Public Key: 30 81 89 02 81 81 00 C9 D7 1C A2 7A D4 DB 46 04 1F D8 E0 94 6D C2 28 0F CF 3A B8 B7 72 BB A8 60 CC 1A DD 6B 23 F8 5C E4 53 60 4F F5 2C E1 0E C7 C4 F3 1E CB A1 93 B3 2D BC B4 4F 85 5E C4 50 1F 68 5D 98 5A 1E 97 D8 83 53 93 97 7F C0 C7 E5 F4 B6 99 BB CD 01 74 9B 63 0E 09 40 9F BD B0 68 D2 CD E8 F7 68 19 6E EE 99 BC 35 52 8F 50 B5 AA 2E E3 68 47 6A A4 F3 9B ED 2C C1 6F 6B DA FD AF 6C 1D 1F 76 DC CC 69 61 02 03 01 00 01
Extended Key Usage
Allowed Purposes:   Server Authentication
Client Authentication
Critical:   No
Subject Alternative Names
DNS:    accounts.google.com
Critical:   No
Basic Constraints
Certificate Authority:  No
Max Path Length:    Unlimited
Critical:   Yes
Signature
Signature Algorithm:    SHA1 with RSA
Signature Parameters:   05 00
Signature:  71 1C 02 A7 E2 F7 7F 83 88 7A E9 63 38 56 8B AC D0 11 05 AE 14 77 36 76 4C FE BA 49 52 D9 70 D9 5B 93 6B AF 6D E5 8D D4 9A 3C A3 3C 05 90 C5 E3 1F 09 05 5E 92 1A A5 8D 70 23 6A 38 B2 C0 31 C0 E5 30 60 1D E4 38 00 2A 65 F6 2C 4B 13 5D 16 96 E2 8E 2E D0 DC 23 89 D4 6E CA A9 E8 04 24 A6 1C DB 1C 31 80 D9 28 94 AD 6F 55 5C 81 32 2F 2A FA 69 7C E4 F7 FB 8F 62 7B D7 EE C4 EB CC FB 9C DB

Why does this happen? How can I solve it?

  • Can you check what kind of certificates you have on Firefox/Chrome? – ryekayo Jul 2 '14 at 12:41
  • If this had been an installed version, I'd have guessed your certificate database had been corrupted: support.mozilla.org/en-US/kb/connection-untrusted-error-message – S.L. Barth Jul 2 '14 at 13:08
  • @ryekayo I added all the certificate I got when trying loging gmail – Yagel Jul 6 '14 at 11:32
  • @Yagel Your connection is being intercepted. NetSpark is a company which provides web filtering stuff. – Lekensteyn Jul 6 '14 at 11:51
  • @Yagel: if you add an exception for NetSpark with gmails email domain, thatll resolve the issue. – ryekayo Jul 6 '14 at 13:27
4

OK,after a lot of tries I understand the problem and find the solution.

Just use this(in hebrew) page in the Internet Rimon ISP site.

פשוט תשתמש בקישור הזה באתר של אינטרנט רימון.

Explanation

my ISP(INTERNET RIMON -only in IL) is a special one. It filtering violence, porn and bad content. But in secure pages they have a problem. they can't look in it... so the solution they fond is simple: 'man in the middle'. they actually take a look in the secured information, and re-encode it using netspark.com certificate. so my data is protected (except what my ISP servers see), but the browser, who doesn't know who is netspark.com, tell me that there is a risk that someone sniffed my information(and that's true..). If i say to the browser who is netspark (and that I trust it) and what is it's certificate (this isn't regular certificate), the browser will work perfectly.

In my case, Because there is no problems in my chrome, I exported the certificate of netspark from chrome, and imported it back to firefox, but the simpler one is in the beginning of the answer.

TIP: If your ISP is INTERNET RIMON (אינטרנט רימון) and you have problems with ssl, your google or somthing related, then you can be sure that the RIMON is the reason.

  • What a wonderful Hashgacha Pratit! A relative of mine had exactly the same problem, and I found your answer 3 hours after you published it. The link you supplied: members.neto.net.il/?a=members/cert worked perfectly. – Erel Segal-Halevi Sep 29 '14 at 10:21
2

Check System date time and timezone in Ubuntu. Provide Proper time and timezone and then try to browse https site. If you have wrong time in your system you will get Untrusted connection error while connecting to site that uses ssl.

  • the time is OK. (How much accuracy is needed?) – Yagel Jul 2 '14 at 19:04
  • You need month year value proper. – Arun Singh Jul 3 '14 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.