1

On Ubuntu 14.04 I tried to dim the screen brightness to 50% on each system start in /etc/rc.local with the line

xbacklight -set 50%

right before the line exit 0

Why does this not work?

Is there a better solution?

2

You cannot call xbacklight in rc.local, because rc.local is not running in the X environment.

Add this command to your startup programs (gnome-session-properties):

xbacklight -set 50%

This will work

0

I use the following command to set my Surface Pro 3's brightness to 50%

xrandr --output eDP-1 --brightness 0.5

There are probably more direct ways to find your output names, but...

I installed and ran arandr. After positioning my displays how I wanted them I saved a layout (they'll show up in ~/.screenlayout/yourLayout.sh)

Then I modified that file to add the --brigtness flag, and configured the script to run at startup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.