How to configure a dummy sound device on a Ubuntu 14.04 server which has no sound HW?

I basically just want various apps, aplay as a concrete target, to be happy, like they'd be if the system had real sound card. How the solution mixes Alsa, Pulseaudio, OSS, or whatever, that doesn't matter.

What I have done currently:

At the moment I have just added this one line to /etc/modules:


and after reboot, lsmod | grep snd output is this:

snd_dummy              20483  0 
snd_pcm               102099  1 snd_dummy
snd_page_alloc         18710  1 snd_pcm
snd_seq_midi           13324  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30144  1 snd_seq_midi
snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              29482  2 snd_pcm,snd_seq
snd                    69238  7 snd_dummy,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_seq_device,snd_seq_midi
soundcore              12680  1 snd

But, it seems I need to do more, because...

What kind of problem I see:

When I run aplay /usr/share/sounds/alsa/Noise.wav, I get:

ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4727:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM default
aplay: main:722: audio open error: No such file or directory

So, how to get this to work? Or how to trouble shoot a sound problem effectively?


Ok, figured it out. It's simply a matter of permissions!

So, complete steps that worked for me, as root:

  • Add snd-dummy line to /etc/modules
  • Edit /etc/group and add desired user(s) to audio:x:29: line (group ID may be different I suppose)
  • Reboot for changes to take effect and verify that they remain in effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.