11

Eclipse luna ships with an integrated dark theme, I downloaded Eclipse CDT and deleted my workspace to reset Eclipse configuration.

I switched to the dark theme and restarted Eclipse; the UI doesn't look like expected: enter image description here

I also have checked for updates within Eclipse (no update found) The theme is supposed to look like the screenshots in the link.

6

Fix text editor colors:

Help > Eclipse Marketplace > Search for "Eclipse Color Theme" and install it.

Then go to: Windows > Preferences > General > Appearance > Color Theme

Fix text boxes colors:

Open a terminal and run

export SWT_GTK3=0

Then start Eclipse :

eclipse

The user interface should be fixed. If this worked for you edit the eclipse launch script for more convenience:

sudo gedit /usr/bin/eclipse

Add

export SWT_GTK3=0

Before:

ECLIPSE=/usr/lib/eclipse/eclipse

Source: https://github.com/guari/eclipse-ui-theme/issues/73

  • 1
    export SWT_GTK3=0 (and = 1) is not working for me. What should i do? – Blaze Tama Nov 7 '14 at 14:31
1

The editor issue should be fixed with Eclipse 4.4.1. On of the Eclipse plug-ins was affecting the styling of the editor.

  • 2
    I'm on Luna Service Release 1 (4.4.1). It's not fixed. – Stealth Rabbi Jan 13 '15 at 20:13
  • For reference, the problem is not yet fixed on 4.4.1, but until a proper fix comes through, Toshihiro's workaround seems to work (although scrollbars and buttons are still kinda crappy). – Neil Traft Feb 16 '15 at 6:04
0

I had problems with a dark theme also. You can try the following:

go to: Windows>Preferences>General>Appearance

and disable: Enable Theming

It might help!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.