0

I am trying to downgrade from libreoffice 4.3.0~rc1 to the most recent stable 4.2.0.

This is on account of this bug .

I have seen this question about How to downgrade to a specific ppa version of libreoffice which suggests

sudo apt-get install libreoffice=version

but I can't figure out how to specify the version.

libreoffice=4-2 or libreoffice=4.2 or libreoffice=4.2.0 all give me variations on

E: Version '4-2' for 'libreoffice was not found

I have also tried

sudo ppa-purge ppa:libreoffice/ppa
sudo add-apt repository ppa:libreoffice/libreoffice-4-2
sudo apt-get update
sudo apt-get install libreoffice

but that also gives me the new, unworking 4.3 version.

Any suggestions? I suppose I could install from the .deb files, but I'd rather use a repository version if possible.

Note that:

apt-cache policy libreoffice
libreoffice:
  Installed: 1:4.3.0~rc1-0ubuntu1~precise0.2
  Candidate: 1:4.3.0~rc1-0ubuntu1~precise0.2
  Version table:
 *** 1:4.3.0~rc1-0ubuntu1~precise0.2 0
        500 http://ppa.launchpad.net/libreoffice/libreoffice-prereleases/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.5.7-0ubuntu6.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
     1:3.5.4-0ubuntu1.1 0
        500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
     1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages 

but "sudo apt-get install libreoffice=1:3.5.7-0ubuntu6.1.0"
returns
"E: Version '1:3.5.7-0ubuntu6.1.0' for 'libreoffice' was not found"
1

Type

apt-cache policy libreoffice

You should get output that looks something like this:

libreoffice:
  Installed: 1:4.2.4-0ubuntu2
  Candidate: 1:4.2.4-0ubuntu2
  Version table:
 *** 1:4.2.4-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/universe amd64 Packages
        100 /var/lib/dpkg/status
     1:4.2.3~rc3-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

The one with *** is your currently installed one (or maybe it's the candidate version.. I'm not positive now that I think of it)

To install specifically, say, the second one (in my case) you would type

sudo apt-get install libreoffice=1:4.2.3~rc3-0ubuntu2
  • I tried this and selected the second one on the list: "sudo apt-get install libreoffice=1:3.5.7-0ubuntu6.1.0" : "E: Version '1:3.5.7-0ubuntu 6.1.0' for libreoffice was not found"; also, I don't see any version 4.2 showing up in the apt-cach policy, any idea why? – ohnoplus Jul 1 '14 at 20:20
  • 1
    Can you edit your original post with the results of apt-cache policy libreoffice? – Mitch Jul 1 '14 at 20:22
  • modified, as requested – ohnoplus Jul 1 '14 at 21:15
  • So while I'm not sure where you'd get it, 1.4.2 is not in any of the ppas/sources that are available to you – Mitch Jul 2 '14 at 13:11
  • I am not trying to install 1.4.2, I am actually trying to install the latest stable version. 4.2.5.2. I went ahead and installed from the .deb file, which seems to work fine for now. – ohnoplus Jul 3 '14 at 0:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.