0

I can not make my newly mounted hdd work properly. First and foremost, I can not access it to read and write any file or folder even after changing the privileges to +775 and even +777 (though I can see the files and directories all right). This is the biggest problem.

Secondly and this is a more theoretical question, when I am trying to unmount it, the system reports that the drive is busy. fuser command shows the drive is busy by a process with c post-fix (2177c). What does this "c" means? I did manage to umnount the hdd using lazy umount thought.

I understand that I am doing smth wrong here. Could you please indicate what my mistake is - I can not figure what can be wrong here using the leads available from google search.

I put in the list of commands I used to mount the hdd and chmod the permissions. Just for a reference - I am doing all that using ssh.

xxx@123 ~ $ mkdir hddmount
xxx@123 ~ $ sudo mount /dev/sda1 /home/xxx/hddmount
xxx@123 ~ $ sudo chmod 775 /home/xxx/hddmount
xxx@123 ~ $ pwd
/home/xxx
xxx@123 ~ $ ls
Desktop  hddmount  Downloads
xxx@123 ~ $ cd hddmount
pi@123 ~/hddmount $ ls
Autorun.inf  Seagate  SeagateExpansion.ico  Setup.exe  Warranty.pdf

xxx@123 ~/hddmount $ mkdir Test
mkdir: cannot create directory `Test': Permission denied
xxx@123 ~/hddmount $ 

mkdir in sudo mode results in:

xxx@123 ~/hddmount $ sudo mkdir Test
mkdir: cannot create directory `Test': Operation not permitted

Why does sudo can not override permissions - this is the third question is am struggling with.


Output of df -h:

/dev/sda0       141G   46G   89G  34% /
none            4.0K     0  4.0K   0% /sys/fs/cgroup
udev            1.5G  4.0K  1.5G   1% /dev
tmpfs           297M  1.5M  295M   1% /run
none            5.0M     0  5.0M   0% /run/lock
none            1.5G  560K  1.5G   1% /run/shm
none            100M   12K  100M   1% /run/user
/dev/sda1       1.9T  150M  1.9T   1% /home/xxx/hddmount
  • Do you have an entry in /etc/fstab for this disk? Is it mounted in a readonly fashion? – Charles Green Jul 1 '14 at 15:15
  • I have not touched /etc/fstab yet (it would my next step) - as I understand for read/write access chmod should do the job. Or am I wrong here? And I can not even read - that's the biggest puzzle for me - only the names of the files are visible.... – VDV Jul 1 '14 at 15:18
  • It's probably a combination of the two. This is a second disk? Can you enter the command df -h and append the output to your question – Charles Green Jul 1 '14 at 15:26
  • If it's an NTFS partition, chmod won't help you. You have to set permissions using mount options (uid=XXXX,gid=YYYY) Presumably you have just execute permission on the folder, no more. What is the output of ls -l /home/xxx/? And the output of mount | grep sda1? – muru Jul 1 '14 at 15:53
  • Right! 99% that is my error! Thanks! – VDV Jul 1 '14 at 16:11
0

This is a 2TB disk (Seagate), so it needed to be mounted with -y ntfs-3g option (presuming ntfs-3g is installed). /etc/fstab should also hold ntfs-3g option, otherwise the problem persists. just adding uid, gid, fmask and dmask options to mount command without the proper file system indication did not work as well in my case.

Many thanks to all!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.