6

I have a laptop that I use on my home LAN, my work LAN and my work VPN via my home LAN through OpenConnect. In addition, I also sometimes use TorGuard, which is a OpenVPN connection. All of these are configured via NetworkManager in nm-applet.

If on my work LAN or work VPN, I must have the private DNS server and search domain because there are a number of servers that only resolve to hostnames within my network and have a standardized DNS suffix. This is set in the nm-applet settings for my work VPN and I have a separate ethernet connection profile for the work LAN.

I am in a situation where regardless of what network I am currently on, I find that at seemingly random but often times I am unable to resolve hostnames and lose my search domain suffix if on my work VPN/LAN.

To fix the problem, and this fix works every time, I have to manually perform a sudo service dnsmasq restart. This resets my DNS servers and search domain to what they are supposed to be and everything works correctly again, for a few minutes.

I keep having to restart the dnsmasq service to fix the domain resolution problem.

Using Ubuntu 14.04 LTS in a Dell Latitude E6540. The ethernet controller is Intel Corporation Ethernet Connection I217-LM (rev 04) and the wifi card Intel® Centrino® Advanced-N 6235.

I've been asked to provide my network devices. I highly doubt hardware is the problem here, but I will humor you. There is one network card and one wifi card. Both work perfectly with the exception of having to restart the dnsmasq service repeatedly to get DNS resolution working.

I sometimes use the wifi, the bluetooth does work but I don't use it for networking. I usually am using ethernet.

  • 2
    I'm at a loss to understand why you're running dnsmasq, all your connections are either normal lan or VPN... just set the DNS entries up in the NetworkManager profiles and be done with it. What's dnsmasq doing for you? If your 'fix' fixes the problem, then dnsmasq is the culprit. Do your connections tend to die around the same length of time from initial connection? Perhaps dnsmasq has a short lease time? (Still not understanding why, but "I'll humor you".) – lornix Jul 8 '14 at 23:17
3
+25

You can check your Dnsmasq configuration here:

$ sudo nano /etc/dnsmasq.conf

I think your best answer you can find here: Special Cases & UFW

Maybe most best is it:

$ sudo ufw allow bootps

Also read above very important part about Local DNS Cache.

0

What you can try doing is open /etc/NetworkManager/NetworkManager.conf and comment out line dns=dnsmasq. Save and sudo service network-manager restart or reboot.

enter image description here

This basically is a line that tells Network Manager to use dnsmasq plug-in; commenting-out prevents Network Manager from using it. Referring to this post from Unix Stackexchange and this one from askubuntu, you'll get a hint that dnsmasq doesn't always do a good job.

Now will things be resolved without that line ? Sure. I have it commented out, and use OpenDNS , as set in configuration for my home network, and Google's public dns at school.

You can also refer to my post here for some more info that may be useful

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.