2

When I try to install GAJ on my machine from the PPA I am presented with the following error:

aptdaemon : Depends: python-aptdaemon (= 0.31+bzr506-0ubuntu6.1) but 0.41+bzr646-0ubuntu2 is to be installed
 gnome-activity-journal : Depends: python-gnome2 but it is not going to be installed
 update-notifier : Depends: update-manager-gnome but it is not installable or
                            update-manager but it is not going to be installed
                   Recommends: apport-gtk but it is not going to be installed
                   Recommends: software-properties-gtk but it is not going to be installed
                   Recommends: anacron but it is not going to be installed
E: Broken packages

When I attempt to resolve the package dependencies it want's to uninstall approximately 1100 packages or the bulk of my running applications. I had no problems using GAJ in 10.10 but this is the first time trying it in 11.04 and I cannot seem to figure out what I'm doing wrong.

2

aptdaemon : Depends: python-aptdaemon (= 0.31+bzr506-0ubuntu6.1)

Notice the = sign. Its dependent on python-aptdaemon of that version. A newer version is being installed in the system. As such, the system is trying to resolve the dependencies by trying to downgrade that package, which explains why everything else is imploding.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.