This question already has an answer here:

I'm trying to get the deb repository for libjansson4 which includes version 2.6-1, but when I go to this page here https://launchpad.net/ubuntu/utopic/amd64/libjansson-dev/2.6-1 I can't get the PPA repository so I can add it to my repositories to download it to my system.

I currently have and old outdated version of libjansson4 on 2.4, and I need 2.5 or greater to try compile this software that depends on it. I did however come to another page which has the libjansson4 >=2.6-1 and it's amd64 build, but when I go to run that deb package I get error saying it has unmet dependencies because it requires libjansson4 to be >=2.5 and up.

 Selecting previously unselected package libjansson-dev:amd64.
 (Reading database ... 303860 files and directories currently installed.)
 Unpacking libjansson-dev:amd64 (from .../libjansson-dev_2.6-1_amd64.deb) ...
 dpkg: dependency problems prevent configuration of libjansson-dev:amd64:
  libjansson-dev:amd64 depends on libjansson4 (= 2.6-1); however:
    Version of libjansson4:amd64 on system is 2.4-1.

dpkg: error processing libjansson-dev:amd64 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:

checking around and I can't seem to get a hold of the debian repositories so I can add them, just where are they and why is it so difficult to get a hold of?

it's really annoying that the current repositories are so outdated, yet on the actual main sources where they can be obtained they have them constantly updated as they release them, more so annoying they don't provide any instructions on how to add their ppa because they didn't say what their ppa repo is like most people put out.

I have considered the option of just taking RPM package and then re-compile that into a DEB package, although that just takes too much time and effort to do.

marked as duplicate by Warren Hill, Eric Carvalho, Panther, bain, psusi Jul 4 '14 at 18:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Yes it's because of unmet dependencies, because I can't get a hold of libjansson4 >=2.6-1 because in the current repo it's got the old outdated <=2.4 version, and I can't compile the software that depends on it. So I need to install libjansson4 and libjansson-dev 2.6-1 so it can continue with what it needs. – user94959 Jul 1 '14 at 13:09

first you need to uninstall the present libjansson4.

sudo apt-get remove libjansson4

If you are having a problem removing it, run:

sudo dpkg -r libjansson4

If it is succeeded or not, then run:

gksudo gedit /var/lib/dpkg/status

In the resulting Gedit , remove the whole section starts with

Package : libjansson4

Then save the file and close.

Then try to install it with the repository.

  • I managed to remove with success and try the deb package again but this time it tells me libjansson4 is not installed. I went to the source on Github and downloaded it and compiled it for my system, ran all the make commands with no errors, so I don't get why it still complains it's not installed when I clearly installed straight from the source? – user94959 Jul 1 '14 at 13:26