3

I know this has been discussed, but I can not find a permanent fix.

I enabled desktop sharing, unchecked "manually approve every access", set a password, and I'm trying from the local network, or via SSH port forwarding as I don't like to permanently open ports from the router.

All the VNC clients I tried say either "Unsupported auth method." "Unknown encryption type". I can see the connection is arriving to my computer with tcpdump, but the clients don't know Ubuntu's method.

A usable workaround is typing in "gsettings set org.gnome.Vino require-encryption false" any time I'm going to remotely access. This means no encryption, but I'm running through a SSH tunnel, so I already have encryption.

I also tried the dconf thing, but I don't understand how to do it. (on the net I found that I need to disable remote access with dconf and set a password there, and whatever). Does anyone know a fix, or maybe a VNC client that knows how to deal with Ubuntu's built in remote desktop server?

  • I don't think it should be necessary to reapply the gsettings fix each time - unless you are running a non-persistent live session...? – steeldriver Jul 1 '14 at 7:49
  • Nope, it's a full install. But that option seems to reset after reboot. Strange condition? Someone suggested to set it using dconf to make it persistent. – Bodo Jul 1 '14 at 10:32
  • Well the dconf version would be dconf write /desktop/gnome/remote-access/require-encryption false I think - but I don't understand why the gsettings version should not persist. – steeldriver Jul 1 '14 at 12:03
-2

My response is probably very late for you, nevertheless it may help you if you haven't found another solution already. The 100% vino compatible VNC client you can use is vinagre. I am using it for years. You can find it in the repos. :)

p.s. Vino is the name of the default VNC server in Ubuntu.

  • I don't see how this answers the encryption problem? – guntbert Dec 29 '14 at 22:18
  • @guntbert: it might do. The newer VNC client/servers have more stringent authentication and encryption then the original, so this just might be the answer the OP is looking for... – Fabby Dec 29 '14 at 22:40

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.