0

Hi when i disconnect the cable from eth1 and reconnect it takes around 30 seconds for the interface to come up and be pingable.

We have checked the cisco port and we have portfast enabled.

We did enable ubuntu to use VLANs.

Eth1 is statically configured.

Any ideas what might cause this delay?

Thanks for your suggestions,

kam270

  • How did you configure ubuntu to use VLANs? I'd look to see if portfast is kicking in on the switch. Reconnect cable and do show spanning-tree interface INTERFACE in IOS see if the port goes into forwarding state FWD right away as expected to rule switch out – meccooll Jul 1 '14 at 6:26
  • The vlan was configured using vlan package. My /etc/network/interfaces #add VLAN 200 on eth1 auto eth1.200 iface eth1.200 inet static address 192.168.100.192 netmask 255.255.255.0 vlan-raw-device eth1 The port has portfast enabled and shows the correct LAN0200 Desg LIS 19 128.32 P2p – Daniel Baker Jul 1 '14 at 6:46
1

That's your problem portfast is not kicking in. Desg LIS 19 128.32 P2p port doesn't forward packets in the Listening state for 15sec, after which it'll go to LRN learning state for another 15sec before finally going into FWD forwarding state. Are you not running RSTP? In any case looks like it's a Cisco question and not Ubuntu

  • Ahh will investigate the CISCO issue more deeply. Thanks – Daniel Baker Jul 2 '14 at 2:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.