1

Pretty simple error. When I try to open "Trash" through Nautilus, I get a dialog box displaying the following:

'Sorry, could not display all the contents of “trash:///”: Operation not supported'

I need a file (several thousand, actually) that I accidentally deleted this morning.

Google has very little to say on this particular error. Most of the forum posts I've found are 5+ years old, or have gone unresolved. So I'm pretty hopeless. Are there any alternatives to using the Trash utility to restore files?

Thanks a lot!

1

The trash directory is located at /home/username/.local/share/Trash .

Underneath that directory, "files" should contain any files you have deleted.

You can try opening nautilus, going to your home directory, and pressing Ctrl + H (The key combination for showing hidden files) and browsing to that path, or you can do it from a terminal.

Take your choice.

I hope that helps.

EDIT1:

You can install trash-cli using "sudo apt-get install trash-cli" for a command line interface to manage your trash. It has a command restore-trash which should do what you are wanting.

EDIT2: Have you tried running "gksudo nautilus", and then going to trash via places, or pressing Ctrl + L and typing trash:/// ?

EDIT3: I have modified the python script that comes with trash-cli for the restore-trash utility to enable multiple restores. (Sorry didn't have enough time to do it from user input, but it will restore the first 10001 items in your trash) Open /usr/lib/python2.7/dist-packages/trashcli/trash.py in a text editor and navigate down to def run(self): replace everything from (and including) that line down to def for_all_trashed_file_in_dir(self, action, dir): with the following:

def run(self):

    trashed_files = []
    self.for_all_trashed_file_in_dir(trashed_files.append, self.curdir())

    if not trashed_files:
        self.report_no_files_found()
    else :
        for i, trashedfile in enumerate(trashed_files):
            self.println("%4d %s %s" % (i, trashedfile.deletion_date, trashedfile.path))
    index=range(10000)
for item in index:
    trashed_files[item].restore()

The next time you run restore-trash it will restore the first 10001 items in your trash.

Let me know if you have any problems, and I wish you the best of luck.

  • Thanks for your answer! Are you saying that I have to manually restore the file structure of over 9000 files? EDIT: To be more clear, when I deleted the files and folders, every folder was extracted from its parent folder and placed in ~/.local/share/Trash. In short, the folder hierarchy is totally screwed up. I do not think a simple mv will solve this issue, if that is what you're implying the solution is. – Dfrtbx Jun 30 '14 at 15:11
  • Response to your edit: Tried it. Ironically, the trash-cli tool (restore-trash, in particular) is itself a piece of trash. Try it out and see what I mean. It only lets you restore a single file at a time... WHY?? EDIT: trash-restore => restore-trash – Dfrtbx Jun 30 '14 at 15:20
  • 'gksudo nautilus' gave me the same error. I tried doing Ctrl + L and typing trash:///, which gave me a dialog box saying "Unable to find the requested file. Please check the spelling and try again. Unhandled error message: Error when getting information for file ~/trash:: No such file or directory" So I thought, "OK, just move your ~/.local/share/Trash to ~/trash", which I did. Then doing a Ctrl + L and typing trash:/// just gave me the same dialog box. (I did make sure to change it to lower "t".) EDIT: specifics – Dfrtbx Jun 30 '14 at 15:59
  • I got rid of the link to .py script and just posted the changed code. – contributor1 Jun 30 '14 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.