Recently, the Unity "Files & Folders" lens can not find anything I am searching for using the dash.

Let's give an example : I want to find a document called "Figure_1.png". Before this trouble, I could write "Fig" in the dash and all the documents starting whose name would contain "Fig" will be displayed in the results.

Since, yesterday, nothing happens and I just got the three types "Recent", "Download" and "Favorite Folders" populated. Even if the document "Figure_1.png" is present in the "Recent" subcategorie, typing "Fig" wouldn't only restrict the result to this document. It seems that the search motor has been killed somehow.

All other lenses behave as expected.

I tried to reinstall the unity-places-files application as well as zeitgeist and log-in/log-out without success.

Also, when I run the command zeitgeist-daemon --replace in a terminal, this error message appears :

ERROR - zeitgeist.extension - Failed loading the 'SearchEngineExtension' extension

I don't know if that might be related to my problem.

Do you know a way to get back this very important feature ?

Thanks for your answers.

  • Try running "sudo updatedb". I am not sure if the files and folders lens uses locate, but it is worth a try. – nickguletskii Jun 16 '11 at 7:40
  • @nickguletskii: No, it uses Zeitgeist. – Javier Rivera Jun 16 '11 at 7:49
  • @nickguletskii : I tried that and also reinstall Unity through Synaptic but the problem is still here. – Alkalyzer Jun 16 '11 at 9:38
  • @Alkalyzer: The problem is likely in Zeitgeist, not unity. You can try to reinstall it. But I don't know enough about it to answer your question. – Javier Rivera Jun 16 '11 at 10:05
  • 1
    This problem might be linked to the following Bug #777866 – Alkalyzer Jun 16 '11 at 11:33

The problem could be in corrupted FTS index. See the bug report.

The solution is to remove the index - this shouldn't affect your overall history of activities.

zeitgeist-daemon --quit
rm -rvf ~/.local/share/zeitgeist/fts.index/
zeitgeist-daemon --replace

(Based on Michal Hruby's solution from the linked bug report.)

  • 1
    After having mentioned that this bug had also affected me on Launchpad, I received a very quick answer from Seif Lotfy which suggested me the same solution as you. And that worked like a charm. So thank you both of you. – Alkalyzer Jun 16 '11 at 19:57
  • 1
    Should I be worried about this error:** (zeitgeist-datahub:6309): WARNING **: zeitgeist-datahub.vala:229: Unable to get name "org.gnome.zeitgeist.datahub" on the bus! – Amanda Dec 2 '13 at 14:19
  • 1
    @Amanda This is probably caused by the daemon being shut down (with zeitgeist-daemon --quit), so there's no reason to worry. – jnv Dec 2 '13 at 21:11
  • 1
    @jnv and ... it worked. Which is a huge relief. – Amanda Dec 3 '13 at 13:16

What do you see when you open folders and places (it) when you open it this is it for me Open the places lens or do you get a just a black empty dash. If you want to realy search you'll have to install unity-places-filesearch the ppa is: http://ppa.launchpad.net/pydave/unity-lenses/ubuntu the normale lens won't search though all the files. After you've installed it you type in terminal unity or log out and back in again.

  • When I opened the "Search Files & Folders" lens, I got exactly the same window as you. I could also write in the dash. It was just that the files didn't get ordered or updated after I had typed the beginning of the name. – Alkalyzer Jun 16 '11 at 20:02
  • @Alkalyzer I don't know it might be a bug I noticed that I've got the same problem. – Rens Jun 16 '11 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.