14

On a freshly installed and updated Ubuntu 14.04 my ThinkPad E540 suspends successfully, but won't wake back up - a full reboot is necessary. Moreover, during the suspended state the fan is constantly working on considerably higher rpm than during normal usage, even though laptop's LED indicates sleep. However, it seems that both hardware and BIOS are OK, since suspend works fine on Windows 7.

I tried out solutions offered on similar problems, most notably this (use Nvidia proprietary drivers instead of noveau) and this, yet the problem persists.

pm-suspend.log reports everything was completed with success, except this:

Failed to connect to non-global ctrl_ifname: (null)  error: No such file or directory

This message is repeated thrice. The log ends with 'performing suspend'.

I really appreciate help with this matter.

EDIT: This procedure also didn't help.

  • 2
    Why did someone vote this question down? Is something not clear? Then why not ask for clarifications? Haven't I searched for possible solutions? My lack of knowledge of Ubuntu does not allow me to do any hardcore research - that's why I asked for help. Moreover, it seems that quite a few people with Thinkpads have similar problems... – mrvlad Jul 4 '14 at 16:27
  • 1
    I also have the same issue on a Lenovo Thinkpad S5 S540. After closing the lid the laptop suspends, and when I re-open the lid I can vaguely see the login-screen and my mouse-pointer. The laptop is completely unresponsive, so I can't open a terminal. I performed the system test (System Testing) and the test fails on the Deep Suspend test. It succeeded on the normal suspend test. Hope this clue helps fixing this problem. – user304503 Jul 11 '14 at 8:09
  • 1
    Still have the issue, none of the solutions below helped me. I suspect it could be related also with Video Drivers – Kostanos Sep 29 '15 at 2:18
5

As user Josiah Stevenson said, the problem really references USB 3 option in BIOS.

Happy to inform you, that the latest BIOS update v.2.20 fully solves this problem. You can download the update from Lenovo Downloads, flash your BIOS and use both USB 3.0 and suspend in Ubuntu.

  • The problem persists in 16.04 LTS. This solution fixed the problem and retained USB 3.0 functionality. – leafpile Aug 8 '16 at 9:06
  • Hmm for my T450 the newest version number is v1.24 – velop Dec 15 '16 at 13:52
9

I have this model and had this issue.

As far as I know, it isn't solved yet, but suspend/wake works as expected if you disable USB 3.0 in the BIOS.

See the bug page at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1340376.

The ports still work as USB 2.0 ports. Haven't thought about the issue in two months.

  • Works like a charm. Thank you for sharing. Nevertheless I hope someone will fix the issue in a way that USB 3.0 functionality will be retained. – mrvlad Oct 4 '14 at 22:18
  • Worked like a charm for my Thinkpad X1 Carbon, which had been having this issue since Ubuntu 12.04. (Get to boot menu with <F12> during boot, then <Tab> to see the <Setup> option.) Thanks! :) – patcon Jan 26 '15 at 4:42
  • How do I disable USB 3.0 in BIOS? – Manas Paldhe Apr 23 '15 at 4:43
  • Hello Josiah,I applied this workaround last year in July 2014 on the Lenovo ThinkPad E540 of my daughter. She always uses Suspend to RAM and with the BIOS disabled USB 3.0 she never had a problem with wakeup again. – pefu May 15 '15 at 9:28
1

I am using a completely different laptop (dell inspiron 1420), but had a similar problem with 14.04. With a timeout suspend (2 hours), upon resuming, keyboard and trackpad do not work. Cannot switch to a terminal.

Workaround seems to be to manually (as suggested above) use the menu to suspend rather than a timeout (or lid closing). After a manual suspend, I wait until the hdd indicator is off and the power indicator is pulsing. I then can close the lid. Upon opening it, keyboard and trackpad work. I have tested this 5 times now.

I also have the password required from suspend option set.

I also have the same Fail statement in my pm-suspend.log. I have the fail statement whether or not I have a successful resume. For that reason, I don't think it is reflective of what is going on.

1

I tried many things. After finding out that hibernate works but suspend does not I changed the settings in /etc/default/acpi-support commenting out ACPI_SLEEP=true Reboot. That did the trick for me. No suspend to RAM.

  • My last try includes a bunch of BIOS changed and this change and it finally worked. Not sure whether this specific change is the solution or not. But at least it doesn’t hurt. Tested on Ubuntu 16.04 in a Thinkpad P52 – Penghe Geng Feb 2 at 5:52
0

TL;DR: you may be able to use a terminal to avoid a full reboot, but I've yet to find a real solution. For me, his only began occurring in the past week, post a round of updates.

I'm the Thinkpad S1 Yoga. Suspending from the menu is fine to resume, but suspends from closing the lid fail to resume. I can see the screen in the state it was in at suspend time, and (sometimes) move my mouse, but no keyboard input is allowed to Unity.

Ctrl-Alt-F# (F1,F2,F3,F4,F5,F6, and F7. F8 Goes to GUI interface) takes me to a terminal where I can pkill myself and re-log in, so it seems to be a problem, for me, in the X/Unity world.

I have integrated Intel graphics, so all the NVidia and AMD solutions aren't helping me :)

UPDATE: Switching to requiring a password after resuming from suspend has provided a good workaround for me that doesn't require pkill.

  • Thanks, but after suspending my keyboard is not responsive and the screen is black, so I cannot invoke a terminal nor do anything useful. – mrvlad Jul 4 '14 at 16:31
  • @mrvlad: Just to be sure: My screen is black and keyboard unresponsive too - but Ctrl-Alt-F2 still takes me to a console where I can log in. – Jonathan Hartley Oct 10 '17 at 15:52
0

I have the same problem with a Lenovo Thinkpad E540, after some research the solution that I found was the following:

1) Remove the BIOS Battery, this can be easily done without mayor tools, it only takes a small Phillips screwdriver since the BIOS battery is located under a small rectangular cap in the back of the laptop.

2) Wait around 10 seconds and reconnect the BIOS battery (this will reboot the BIOS entirely).

This procedure will make the laptop turn on normally but it will require to set up the BIOS date and any other personal configurations.

In the topic of how to solve this issue, there is a temporary solution and a possible final solution that I am still testing:

1) Like user Josiah Stevenson said, disable the USB 3.0 in the BIOS, this worked for me for around 3 months but then the problem appeared again.

2) Do an Upgrade of the BIOS; like a said before I'm still testing if this solves the problem permanently, so far it has only been a couple of days so I can't say if this procedure will solve the issue.

protected by Community Nov 16 '14 at 0:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.