21

I recently installed Ubuntu 14.04 alongside Windows 7 on my Asus (i5 core and 8GB Ram).

I experience frequent freezes of my screen. I cannot move the mouse, but I can use the keyboard. When it happens I could always open a command line with Ctrl+Alt+F2 and do sudo service lightdm restart to restart graphics.

But that of course does not fix the problem and is rather annoying since it happens rather often.

How I can find and fix the underlying issue here?

Greets and thanks in advance

3
  • 2
    Why did this question got downvoted? It's a legitimate question. I'm experiencing similar problem. Aug 5, 2014 at 7:00
  • 1
    hint: no need to restart lightdm. simple switch to other tty, and then switch back to C-A-F7.
    – vp_arth
    Aug 3, 2015 at 19:07
  • 1
    Check if your xorg get the mouse events correctly, login open a Terminal and enter: <code>$ xev</code> If your mouse freezes and <code>xev</code> doesn't show anything, when you use the mouse, then you have a driver issue.
    – Arch User
    Sep 6, 2015 at 14:20

7 Answers 7

10

I get it occasionally in 12.04 LTS. control+ALT+t will usually open a terminal window. modprobe -r psmouse followed by modprobe psmouse will usually fix it.

Check RAM by booting into GRUB. Boot holding shift down, then test memory.

1
  • This seems to have worked in ubuntu 17.10. Having to do this every time when my machine first boots will be annoying Feb 28, 2018 at 10:44
3

Reinstall the mouse driver :

sudo apt-get --reinstall install xserver-xorg-input-mouse
4
  • Thanks for the tip. I did that, but the problem keeps appearing. Jun 30, 2014 at 16:25
  • +1 This appears to have fixed the problem for me.
    – z7sg
    Jun 19, 2015 at 9:50
  • 1
    I guess this does not work for people who are not currently connected to the Internet? Jan 3, 2017 at 8:10
  • 1
    i got unmet dependencies, of xorg-input-abi-20 and xserver-xorg-core(>= 2:1.14.99.902). Synaptic showed that xserver-xorg-input-mouse is broken. I looked at libevdev2, and it also had some broken dependencies and synaptic solved somethings for me, I am not sure what happened. My mouse is working at the moment, will update once I am sure Dec 29, 2017 at 11:00
1

This is maybe a process who reach 100% cpu usage a short amount of time? Install htop & look if a process is reatching 100% cpu usage.

This is something I encounter with multiple instances of vlc or some others applications.

0

I also experienced a screen freeze problem similar to the one you described, after a recent upgrade from Ubuntu 12.04 to 14.04. The upgrade also led to occasional forced logout. My computer is running on an Intel i5 CPU and 4GB RAM.

I used htop to investigate what processes were keeping my CPU busy. I saw a suspicious process compiz and wondered what that was - this turned out to be a program used by the Unity window manager to enhance window graphics. So maybe those fancy graphic effects were slowing down my computer, I thought. Without further investigation, I tried my luck by switching to the LXDE window manager that is reputed to be light weighted.

sudo apt-get install lubuntu-desktop

Log out, then log in again selecting lubuntu.

I am so far very happy with the switch. User interaction has sped up. And I think the GUI is intuitive to a Windows user.

0

You could try this:

    dconf -reset -f /org/compiz
    gsettings set org.gnome.settings-plugin.mouse KEY="s.mouse" VALUE="false"
    sudo dpkg-reconfigure unity

and it might work fine this way.

0
xev

shows I have no input from mouse buttons or scroll wheels when this occurs.

sudo apt-get install  xserver-xorg-input-mouse

shows unmet dependencies in xorg-input-abi-20 and xserver-xorg-core.

This was all working 5 minutes ago, and this is a relatively fresh (1 month) install of Ubuntu 14.04 on a new brainbox.

Not sure what to do next. Mouse works for several days, then freezes, cursor moves but not able to pick or scroll.

Conky says CPU usage is 1%. Should be good to go. top says the usual suspects are running - chrome, thunderbird, nobody's hogging any CPU.

So far I've been hammering it with Alt-F2 sudo service restert lightdm, that's crude but at least I can move on.

/EDIT tried sudo apt-get update, sudo apt-get -f install, sudo apt-get autoremove. Still have unmet dependencies. Today the mouse is working fine, this is a very intermittent problem.

-3

Go to nvidia settings, profiles, and switch to Intel Power Saving. Logout and back in.

1
  • 5
    Consider adding a bit more about what you think might be the problem and solution.
    – Requist
    Dec 15, 2014 at 19:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.