I want to make a bootable live USB from Ubuntu 14.04. When I insert a free USB, Startup Disk Creator says Capacity: 7.5GB; Free 0.0GB.

This is a free and working USB, as I can copy file on it. I tried to format it several times with GParted and Disk, but still the same result.

When I hit Erase in Startup Disc Creator, it gives the following error:

org.freedesktop.DBus.Python.gi._glib.GError: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/usb-creator/usb-creator-helper", line 239, in Format
    block.call_format_sync('dos', GLib.Variant('a{sv}', {'erase': GLib.Variant('s', '')}), None)
gi._glib.GError: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error synchronizing after initial wipe: Timed out waiting for object

How can I safely format and create a live USB?


The error "Failed: Error synchronizing after initial wipe: Timed out waiting for object" comes up with a bug report at ubuntu launchpad see - https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/1307627. Try using another usb just to eliminate a hardware fault.


If you have windows/Mac, format it to FAT/NTFS partition and try again. Obviously there should be some other Linux solution, but this is the quickest ;)

  • The better answer is to use gparted to format the drive to FAT32. – user21627 Dec 18 '14 at 1:39

I had the same error. in my case, I discovered I had mapped some days before another device (my phone) as /dev/sdb in /etc/fstab file, for automounting. I removed the entry, restarted, and then I can use the startup disk utility as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.