2

I'm trying to do a recording of my screen under Ubuntu 14.04 (Unity) with RecordMyDesktop. I'm posting here screenshots of its config. Also, I'm using dual monitor, and I want to select only one. So I selected it "as window". I tried giving the display as a command line argument, same result. I tried running as root, same result: "Cannot connect to X Server".

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

And, this is what happens every time: enter image description here

2
+25

I'm not sure but the value for Misc -> Display might be the problem. You could try setting the appropriate value for the display you're trying to record.

This link should help you to check the available displays; with command:

w -hs | awk '{print $3}' | sort -u

For me the default value works which is :0.0

  • I will try. Selecting the monitor might solve, especially because i have two monitors hooked up. – Bodo Jul 14 '14 at 13:47
  • @Bodo, didn't that help? – precise Jul 22 '14 at 11:59
0

According to this, it is not the display parameter, but the coordinates. Try something like

recordmydesktop --display=0 --width=1920 height=1080 --fps=15 --no-sound --delay=10

on the command line, with your correct values for width and height of course.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.