2

So somebody is letting me use their laptop with Ubuntu 13.10 on it, as my own laptop is currently needing repairs. I'm very new to Linux in general, so it's like I'm learning computers all over again.

At the moment, I would like to use my 3 TB Seagate External Hard drive, but it doesn't seem to be working on here. For a while, I got no reaction from plugging it in aside from the Hard Drive turning on; the laptop didn't seem to acknowledge its existence. Just briefly today, however, it noticed it when I plugged it in. It then disappeared, and I received this message

As I mentioned before, I'm very new to Linux as a whole, so I can't derive a whole lot of information from this. Another problem is that the person letting me use this laptop doesn't know their password, so I'm restricted from using a lot of commands. If at all possible, I'd like a method that doesn't require the password, or if you happen to know how, a way to reset the password.

If you need me to provide any more information, I'll do as much as I can. Any help would be appreciated.

  • The error message actually tells you what needs to be done - "...run chkdsk /f on Windows...". – mikewhatever Jun 30 '14 at 2:57
  • Hi Mike, thanks for the reply. I'm unfortunately not running a dual boot, nor do I have access to Windows via flash drive or disc, so I currently have no way to run the command through windows, as far as I am aware. So from what I've gathered, this means that the problem lies with the hard drive itself, rather than the laptop I am using, and I need to repair the hard drive through a windows operating system? I haven't run into a problem like this until now, and last time I tried the hard drive on a Windows OS, it worked fine. I am rather confused, but I shall attempt that command when I can. – user299053 Jun 30 '14 at 7:56
1

I had the same issue recently. When I googled I found out that I need to boot up with Windows and run ckdsk /f or probably the same thing from GUI, via properties menu of a disk. I could believe that Ubuntu can not fix it itself...But it really does the trick.

NTFS is a closed source Microsoft file system, and you'll need Windows to repair it, by running chkdsk /f, as suggested. So, Ubuntu is not going to make as assumption what caused the changes on NTFS that it looks strange, and moreover not going to fix it relying on assumptions.

Give it a try.

  • You can repair a NTFS partition from Linux. Run fsck.ntfs /dev/<device-partition> – aroll605 Jun 30 '14 at 4:12
1

Either run chkdsk from Windows or

sudo umount /dev/<partition>
sudo fsck.ntfs /dev/<partition>

from linux.

0

Recently did this exactly thing with WD Passport 4Tb. It appears that you removed the external HD before Ubuntu said you could. You have to eject it and wait for the message that says its safe to remove .. not to be confused with message that says it is writing to it. The "chkdsk /f" on Windows will make the drive usable again, but lots of stuff can be missing when it's over. I lost 2.5Tb of data. Make sure you run "chkdsk /f E:" on your drive at least twice.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.