1

I have the TP-LINK TL-WN751ND. I only bought it and fitted it in the last week. However, it has been causing a lot of issues. Before I bought this PCI card, I researched online to see if it was compatible with Ubuntu. I saw a lot of reports of it causing older versions (with older kernels) to freeze after a few minutes of operation, but I also saw a lot of those reports which also said this problem was fixed in a version of Ubuntu much older than 14.04 (around 12.04 if I recall). I also saw reports that this card works perfectly in 12.10. So I thought it would be fine, considering the amount of people reporting it works perfectly.

At first, I thought it had worked, it connected straight away with no problems, but after a while it began to disconnect itself after a few minutes of usage, and once it had disconnected itself you could not re-connect because the amount of networks available in the menu had drastically dropped from around 5 or 6, to just 2. Unfortunately, my router was not one of those 2. And from then on, the majority of the time it was only those 2 that would show up. And sometimes it was just 1. Sometimes, though, my router would show up, and it would connect just fine. However, after a few minutes of usage we end up back to square one.

I've looked around a lot, tried various solutions to do with the this card and similar and none of them seem to have worked. Before I go and buy a different card, I want to see if a bespoke question might get some answers. This is actually the second card I have tried now too.

Here are some generic points of interest related to the problem:

  • The operating system is Ubuntu 14.04 64 bit.
  • The card is a TP-LINK TL-WN751ND.
  • The chipset is a AR9227.
  • The card is near-on brand new, and is the second card I have tried with Ubuntu.

Also, on a side note, does anybody know of any PCI (not PCI-E, or USB) wifi cards that are known to work without a hitch on Ubuntu?

Regards

7
  • Please run the script that is in the accepted answer in the link below so we may see the information needed to help diagnose the issue. <askubuntu.com/questions/425155/…> – Wild Man Jun 29 '14 at 21:54
  • pastebin.ubuntu.com/7723547 – thephpdev Jun 29 '14 at 22:03
  • Have you tried any driver parameters? What country are you in so we can see if your router is set to the right one. – Wild Man Jun 29 '14 at 22:08
  • Hmm, I'm not entirely sure. Networking is not my forte. Anyway, I am in the UK. The router at hand is a new Sky router (link: sky.com/products/kit/sky-hub). – thephpdev Jun 29 '14 at 22:12
  • Your router setting is for China, so I guess we need to change it to the UK. – Wild Man Jun 29 '14 at 22:15
0

We are changing the country code first, do:

sudo sed -i 's/^REG.*=$/&UK/' /etc/default/crda

Then do:

echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf
sudo modprobe -rfv ath9k
sudo modprobe -v ath9k

In the router set your encryption to WPA2 not mixed mode. Change the channel to 1 or 11 they usually work best. Save the router configuration, then reboot router and computer and unplug wired connection.

Set your wireless settings in network manager to match the screenshots.DNS SettingsIPV6 Setting Then reboot.

10
  • Hi, all commands executed without a hitch, however the problem persists. Can't see my router or any of the others I could see in the beginning. – thephpdev Jun 29 '14 at 23:34
  • Run the script again and post the new info file so we can see the changes. Run this command sudo gedit /etc/modprobe.d/ath9k.conf and post the contents of the file. – Wild Man Jun 29 '14 at 23:36
  • Ok: wireless-info.txt: pastebin.ubuntu.com/7725202 and ath9k.conf: pastebin.ubuntu.com/7725204 – thephpdev Jun 30 '14 at 7:48
  • Also, I'd like to add, the amount of networks increased this morning, and I managed to connect. I had good signal, but is disconnected itself after 10 minutes. – thephpdev Jun 30 '14 at 7:50
  • Are you sure that you are not having any issues with your router? The country code did not save so we will do it manually. sudo gedit /etc/rc.local above the exit0 add this line iw reg set GB Proofread carefully, save and close gedit. Reboot. Is this the network you want to connect too SKYA290D? if so please change the channel to 1 or 11. – Wild Man Jun 30 '14 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.